|SSH_CONFIG(5)||File Formats Manual||SSH_CONFIG(5)|
OpenSSH SSH client configuration files
ssh(1) obtains configuration data from the following sources in the following order:
For each parameter, the first obtained value will be used. The configuration files contain sections separated by “Host” specifications, and that section is only applied for hosts that match one of the patterns given in the specification. The matched host name is the one given on the command line.
Since the first obtained value for each parameter is used, more host-specific declarations should be given near the beginning of the file, and general defaults at the end.
The configuration file has the following format:
Empty lines and lines starting with
#’ are comments. Otherwise a line is
of the format “keyword arguments”. Configuration options may
be separated by whitespace or optional whitespace and exactly one
=’; the latter format is useful to
avoid the need to quote whitespace when specifying configuration options
-o option. Arguments
may optionally be enclosed in double quotes (") in order to represent
arguments containing spaces.
The possible keywords and their meanings are as follows (note that keywords are case-insensitive and arguments are case-sensitive):
Matchkeyword) to be only for those hosts that match one of the patterns given after the keyword. If more than one pattern is provided, they should be separated by whitespace. A single ‘
*’ as a pattern can be used to provide global defaults for all hosts. The host is the hostname argument given on the command line (i.e. the name is not converted to a canonicalized host name before matching).
A pattern entry may be negated by prefixing it with an
exclamation mark (‘!’). If a negated entry is matched,
Host entry is ignored, regardless of
whether any other patterns on the line match. Negated matches are
therefore useful to provide exceptions for wildcard matches.
See PATTERNS for more information on patterns.
Matchkeyword) to be used only when the conditions following the
Matchkeyword are satisfied. Match conditions are specified using one or more keyword/criteria pairs or the single token
allwhich matches all criteria. The available keywords are:
exec keyword executes the
specified command under the user's shell. If the command returns a zero
exit status then the condition is considered true. Commands containing
whitespace characters must be quoted. The following character sequences
in the command will be expanded prior to execution:
%L’ will be substituted by the
first component of the local host name,
%l’ will be substituted by the
local host name (including any domain name),
%h’ will be substituted by the
target host name, ‘
%n’ will be
substituted by the original target host name specified on the
%p’ the destination
%r’ by the remote login
username, and ‘
%u’ by the username
of the user running
The other keywords' criteria must be single entries or
comma-separated lists and may use the wildcard and negation operators
described in the PATTERNS section.
The criteria for the
host keyword are matched
against the target hostname, after any substitution by the
Hostname option. The
originalhost keyword matches against the
hostname as it was specified on the command-line. The
user keyword matches against the target username
on the remote host. The
matches against the name of the local user running
ssh(1) (this keyword may be
useful in system-wide
UsePrivilegedPortis set to “yes”.
CanonicalizeHostnameis enabled, this option specifies the list of domain suffixes in which to search for the specified destination host.
CanonicalizeHostnameis enabled and the target hostname cannot be found in any of the domains specified by
ProxyCommand, ssh(1) will attempt to canonicalize the hostname specified on the command line using the
CanonicalizeHostnameis set to “always”, then canonicalization is applied to proxied connections too.
If this option is enabled and canonicalisation results in the
target hostname changing, then the configuration files are processed
again using the new target name to pick up any new configuration in
For example, “*.a.example.com:*.b.example.com,*.c.example.com” will allow hostnames matching “*.a.example.com” to be canonicalized to names in the “*.b.example.com” or “*.c.example.com” domains.
The default is:
aes128-ctr,aes192-ctr,aes256-ctr, email@example.com,firstname.lastname@example.org, email@example.com, arcfour256,arcfour128, aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc, aes192-cbc,aes256-cbc,arcfour
The list of available ciphers may also be obtained using the
-Q option of
ControlPathargument. Additional sessions can connect to this socket using the same
ControlMasterset to “no” (the default). These sessions will try to reuse the master instance's network connection rather than initiating new ones, but will fall back to connecting normally if the control socket does not exist, or is not listening.
Setting this to “ask” will cause ssh to listen
for control connections, but require confirmation using the
SSH_ASKPASS program before they are accepted
(see ssh-add(1) for
details). If the
ControlPath cannot be opened,
ssh will continue without connecting to a master instance.
X11 and ssh-agent(1) forwarding is supported over these multiplexed connections, however the display and agent forwarded will be the one belonging to the master connection i.e. it is not possible to forward multiple displays or agents.
Two additional options allow for opportunistic multiplexing: try to use a master connection but fall back to creating a new one if one does not already exist. These options are: “auto” and “autoask”. The latter requires confirmation like the “ask” option.
ControlMastersection above or the string “none” to disable connection sharing. In the path, ‘
%L’ will be substituted by the first component of the local host name, ‘
%l’ will be substituted by the local host name (including any domain name), ‘
%h’ will be substituted by the target host name, ‘
%n’ will be substituted by the original target host name specified on the command line, ‘
%p’ the destination port, ‘
%r’ by the remote login username, ‘
%u’ by the username of the user running ssh(1), and ‘
%C’ by a hash of the concatenation: %l%h%p%r. It is recommended that any
ControlPathused for opportunistic connection sharing include at least %h, %p, and %r (or alternatively %C). This ensures that shared connections are uniquely identified.
ControlMaster, specifies that the master connection should remain open in the background (waiting for future client connections) after the initial client connection has been closed. If set to “no”, then the master connection will not be placed into the background, and will close as soon as the initial client connection is closed. If set to “yes”, then the master connection will remain in the background indefinitely (until killed or closed via a mechanism such as the ssh(1) “
-Oexit” option). If set to a time in seconds, or a time in any of the formats documented in sshd_config(5), then the backgrounded master connection will automatically terminate after it has remained idle (with no client connections) for the specified time.
The argument must be
addresses can be specified by enclosing addresses in square brackets. By
default, the local port is bound in accordance with the
GatewayPorts setting. However, an explicit
bind_address may be used to bind the connection to
a specific address. The bind_address of
“localhost” indicates that the listening port be bound for
local use only, while an empty address or ‘*’ indicates
that the port should be available from all interfaces.
Currently the SOCKS4 and SOCKS5 protocols are supported, and ssh(1) will act as a SOCKS server. Multiple forwardings may be specified, and additional forwardings can be given on the command line. Only the superuser can forward privileged ports.
HostbasedAuthentication. The argument must be “yes” or “no”. The default is “no”. This option should be placed in the non-hostspecific section. See ssh-keysign(8) for more information.
~’). The escape character can also be set on the command line. The argument should be a single character, ‘
^’ followed by a letter, or “none” to disable the escape character entirely (making the connection transparent for binary data).
Agent forwarding should be enabled with caution. Users with the ability to bypass file permissions on the remote host (for the agent's Unix-domain socket) can access the local agent through the forwarded connection. An attacker cannot obtain key material from the agent, however they can perform operations on the keys that enable them to authenticate using the identities loaded into the agent.
DISPLAYset. The argument must be “yes” or “no”. The default is “no”.
X11 forwarding should be enabled with caution. Users with the
ability to bypass file permissions on the remote host (for the user's
X11 authorization database) can access the local X11 display through the
forwarded connection. An attacker may then be able to perform activities
such as keystroke monitoring if the
ForwardX11Trusted option is also enabled.
If this option is set to “no”, remote X11 clients will be considered untrusted and prevented from stealing or tampering with data belonging to trusted X11 clients. Furthermore, the xauth(1) token used for the session will be set to expire after 20 minutes. Remote clients will be refused access after this time.
The default is “no”.
See the X11 SECURITY extension specification for full details on the restrictions imposed on untrusted clients.
GatewayPortscan be used to specify that ssh should bind local port forwardings to the wildcard address, thus allowing remote hosts to connect to forwarded ports. The argument must be “yes” or “no”. The default is “no”.
firstname.lastname@example.org, email@example.com, firstname.lastname@example.org, email@example.com, firstname.lastname@example.org,email@example.com, firstname.lastname@example.org,email@example.com, ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521, ssh-ed25519,ssh-rsa,ssh-dss
If hostkeys are known for the destination host then this default is modified to prefer their algorithms.
%h’, then this will be replaced with the host name specified on the command line (this is useful for manipulating unqualified names). The character sequence ‘
%%’ will be replaced by a single ‘
%’ character, which may be used when specifying IPv6 link-local addresses.
The default is the name given on the command line. Numeric IP
addresses are also permitted (both on the command line and in
ssh_configfiles, even if ssh-agent(1) or a
PKCS11Provideroffers more identities. The argument to this keyword must be “yes” or “no”. This option is intended for situations where ssh-agent offers many different identities. The default is “no”.
IdentitiesOnlyis set. ssh(1) will try to load certificate information from the filename obtained by appending -cert.pub to the path of a specified
The file name may use the tilde syntax to refer to a user's
home directory or one of the following escape characters:
%d’ (local user's home
%u’ (local user
%l’ (local host name),
%h’ (remote host name) or
%r’ (remote user name).
It is possible to have multiple identity files specified in
configuration files; all these identities will be tried in sequence.
IdentityFile directives will add to the
list of identities tried (this behaviour differs from that of other
IdentityFile may be used in
IdentitiesOnly to select which
identities in an agent are offered during authentication.
ssh_configcontains options that are unrecognised by ssh(1). It is recommended that
IgnoreUnknownbe listed early in the configuration file as it will not be applied to unknown options that appear before it.
firstname.lastname@example.org, ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521, diffie-hellman-group-exchange-sha256, diffie-hellman-group14-sha1, diffie-hellman-group-exchange-sha1, diffie-hellman-group1-sha1
%d’ (local user's home directory), ‘
%h’ (remote host name), ‘
%l’ (local host name), ‘
%n’ (host name as provided on the command line), ‘
%p’ (remote port), ‘
%r’ (remote user name) or ‘
%u’ (local user name) or ‘
%C’ by a hash of the concatenation: %l%h%p%r.
The command is run synchronously and does not have access to the session of the ssh(1) that spawned it. It should not be used for interactive commands.
This directive is ignored unless
PermitLocalCommand has been enabled.
GatewayPortssetting. However, an explicit bind_address may be used to bind the connection to a specific address. The bind_address of “localhost” indicates that the listening port be bound for local use only, while an empty address or ‘*’ indicates that the port should be available from all interfaces.
email@example.com,firstname.lastname@example.org, email@example.com,firstname.lastname@example.org, email@example.com,firstname.lastname@example.org, hmac-sha2-256,hmac-sha2-512, email@example.com,firstname.lastname@example.org, email@example.com, firstname.lastname@example.org,email@example.com, hmac-md5,hmac-sha1,hmac-ripemd160, hmac-sha1-96,hmac-md5-96
LocalCommandoption or using the
!command escape sequence in ssh(1). The argument must be “yes” or “no”. The default is “no”.
keyboard-interactive) over another method (e.g.
password). The default is:
sshwill try version 2 and fall back to version 1 if version 2 is not available. The default is ‘2’.
exec’ directive to avoid a lingering shell process.
In the command string, any occurrence of
%h’ will be substituted by the
host name to connect, ‘
%p’ by the
port, and ‘
%r’ by the remote user
name. The command can be basically anything, and should read from its
standard input and write to its standard output. It should eventually
connect an sshd(8) server
running on some machine, or execute
somewhere. Host key management will be done using the HostName of the
host being connected (defaulting to the name typed by the user). Setting
the command to “none” disables this option entirely. Note
CheckHostIP is not available for connects
with a proxy command.
This directive is useful in conjunction with nc(1) and its proxy support. For example, the following directive would connect via an HTTP proxy at 192.0.2.0:
ProxyCommand /usr/bin/nc -X connect -x 192.0.2.0:8080 %h %p
ProxyCommandwill pass a connected file descriptor back to ssh(1) instead of continuing to execute and pass data. The default is “no”.
RekeyLimitis “default none”, which means that rekeying is performed after the cipher's default amount of data has been sent or received and no time based rekeying is done. This option applies to protocol version 2 only.
If the port argument is
0’, the listen port will be
dynamically allocated on the server and reported to the client at run
If the bind_address is not specified,
the default is to only bind to loopback addresses. If the
*’ or an empty string, then the
forwarding is requested to listen on all interfaces. Specifying a remote
bind_address will only succeed if the server's
GatewayPorts option is enabled (see
-Tflags for ssh(1).
AcceptEnvin sshd_config(5) for how to configure the server. Variables are specified by name, which may contain wildcard characters. Multiple environment variables may be separated by whitespace or spread across multiple
SendEnvdirectives. The default is not to send any environment variables.
See PATTERNS for more information on patterns.
TCPKeepAlive(below). The server alive messages are sent through the encrypted channel and therefore will not be spoofable. The TCP keepalive option enabled by
TCPKeepAliveis spoofable. The server alive mechanism is valuable when the client or server depend on knowing when a connection has become inactive.
The default value is 3. If, for example,
ServerAliveInterval (see below) is set to 15 and
ServerAliveCountMax is left at the default, if
the server becomes unresponsive, ssh will disconnect after approximately
45 seconds. This option applies to protocol version 2 only.
The default value is 0177, which creates a Unix-domain socket file that is readable and writable only by the owner. Note that not all operating systems honor the file mode on Unix-domain socket files.
StreamLocalBindUnlinkis not enabled,
sshwill be unable to forward the port to the Unix-domain socket file. This option is only used for port forwarding to a Unix-domain socket file.
The argument must be “yes” or “no”. The default is “no”.
The default is “yes” (to send TCP keepalive messages), and the client will notice if the network goes down or the remote host dies. This is important in scripts, and many users want it too.
To disable TCP keepalive messages, the value should be set to “no”.
The argument must be local_tun[:remote_tun]. The devices may be specified by numerical ID or the keyword “any”, which uses the next available tunnel device. If remote_tun is not specified, it defaults to “any”. The default is “any:any”.
RhostsRSAAuthenticationwith older servers.
StrictHostKeyCheckingoption. The argument must be “yes”, “no”, or “ask”. The default is “no”. Note that this option applies to protocol version 2 only.
See also VERIFYING HOST KEYS in ssh(1).
A pattern consists of zero or more non-whitespace characters, ‘*’ (a wildcard that matches zero or more characters), or ‘?’ (a wildcard that matches exactly one character). For example, to specify a set of declarations for any host in the “.co.uk” set of domains, the following pattern could be used:
The following pattern would match any host in the 192.168.0.[0-9] network range:
A pattern-list is a comma-separated list of patterns. Patterns within pattern-lists may be negated by preceding them with an exclamation mark (‘!’). For example, to allow a key to be used from anywhere within an organization except from the “dialup” pool, the following entry (in authorized_keys) could be used:
OpenSSH is a derivative of the original and free ssh 1.2.12 release by Tatu Ylonen. Aaron Campbell, Bob Beck, Markus Friedl, Niels Provos, Theo de Raadt and Dug Song removed many bugs, re-added newer features and created OpenSSH. Markus Friedl contributed the support for SSH protocol versions 1.5 and 2.0.
|July 15, 2014||OpenBSD-5.6|