|RTSOLD(8)||System Manager's Manual||RTSOLD(8)|
] interface ...
] interface ...
rtsoldis the daemon program to send ICMPv6 Router Solicitation messages on the specified interfaces. If a node (re)attaches to a link,
rtsoldsends some Router Solicitations on the link destined to the link-local scope all-routers multicast address to discover new routers and to get non link-local addresses.
rtsoldshould be used on IPv6 hosts (non-router nodes) only. The net.inet6.ip6.forwarding sysctl(8) should be set to zero and the net.inet6.icmp6.rediraccept sysctl(8) should be set to a non-zero value (see also the
-Foption below). If you invoke the program as
rtsol, it will transmit probes from the specified interface, without becoming a daemon. In other words,
rtsolbehaves as “rtsold -f1 interface ...”. An interface may be configured at boot to be brought up using
rtsolvia a hostname.if(5) file. See that man page for more information.
rtsoldsends at most 3 Router Solicitations on an interface after one of the following events:
rtsolddetects such failures by periodically probing to see if the status of the interface is active or not. Note that some network cards and drivers do not allow the extraction of link state. In such cases,
rtsoldcannot detect the change of the interface status.
-moption is specified and the
rtsolddaemon cannot get the interface status. This feature does not conform to the IPv6 neighbor discovery specification, but is provided for mobile stations. The default interval for router advertisements, which is on the order of 10 minutes, is slightly long for mobile stations. This feature is provided for such stations so that they can find new routers as soon as possible when they attach to another link.
rtsoldhas sent a Router Solicitation, and has received a valid Router Advertisement, it refrains from sending additional solicitations on that interface, until the next time one of the above events occurs. When sending a Router Solicitation on an interface,
rtsoldincludes a Source Link-layer address option if the interface has a link-layer address.
rtsoldis able to do some additional configuration for interfaces where more than setting the host's address is needed. When the daemon receives a router advertisement with the “Other Configuration” flag set, the script specified using the
-Ooption is run. Upon receipt of signal
rtsoldwill dump the current internal state into /var/run/rtsold.dump. The options are as follows:
rtsoldwill try to find any non-loopback, non-point-to-point, IPv6-capable interfaces, and send router solicitation messages on all of them.
-doption) including the printing of internal timer information.
rtsold(see above). Without this option,
rtsoldwill obey the current sysctl(8) settings.
rtsoldfrom becoming a daemon (foreground mode). Warning messages are generated to standard error instead of syslog(3).
rtsoldsends probing packets to default routers that have advertised Router Advertisements when the node (re)attaches to an interface. Moreover, if the option is specified,
rtsoldperiodically sends Router Solicitation on an interface that does not support
rtsoldutility exits 0 on success, and >0 if an error occurs. hostname.if(5), netstart(8), rtadvd(8), sysctl(8)
rtsoldcommand is based on the
rtsolcommand, which first appeared in WIDE/KAME IPv6 protocol stack kit.
rtsolis now integrated into
rtsoldassumes such changes will not occur, and always uses the index that it got at invocation. As a result,
rtsoldmay not work if you reinsert a network card. In such a case,
rtsoldshould be killed and restarted. The IPv6 autoconfiguration specification assumes a single-interface host. You may see kernel error messages if you try to autoconfigure a host with multiple interfaces. Also, it seems contradictory for
rtsoldto accept multiple interface arguments.
|July 11, 2014||OpenBSD-5.6|