|RC.CONF(8)||System Manager's Manual||RC.CONF(8)|
rc.confcontains a series of variable assignments that are used to configure the system daemons. These variables are read by rc(8) early on in the boot sequence and every time an rc.d(8) script is executed.
It is advisable to leave
untouched, and instead create and edit a new
rc.conf.local file. Variables set in this file will
override variables previously set in
rc.conf is made up of variable assignments
(variable=value) with comments
designated by a hash mark (‘#’).
Some variables are used to turn features on or off. For example, whether the system runs the dhcpd(8) daemon is determined by the following line:
To run the dhcpd daemon, add the following line to
If instead some options are specified, then the dhcpd daemon will be started with those options. For example:
Other variables specify a simple YES or NO, or simply determine the location of a file. For example, the location of the ruleset for pf(4) is given thus:
pf_rules=/etc/pf.conf # Packet filter rules file
Finally there is the pkg_scripts variable, responsible for starting and stopping rc.d(8) scripts installed by packages in the specified order. For example:
This will run /etc/rc.d/dbus_daemon then /etc/rc.d/cupsd with the start argument at boot time, and in reverse order with the stop argument at shutdown.
rc.conffile first appeared in OpenBSD 2.2.
|July 13, 2014||OpenBSD-5.6|