OpenBSD manual page server

Manual Page Search Parameters

OPENPROM(4) Device Drivers Manual (macppc) OPENPROM(4)

openpromOPENPROM interface

#include <machine/openpromio.h>

The file /dev/openprom is an interface to the Macintosh OPENPROM. This interface is highly stylized; ioctls are used for all operations. These ioctls refer to “nodes”, which are simply “magic” integer values describing data areas. Occasionally the number 0 may be used or returned instead, as described below.

The calls that take and/or return a node use a pointer to an int variable for this purpose; others use a pointer to a struct opiocdesc descriptor, which contains a node and two counted strings. The first string is comprised of the fields op_namelen (an int) and op_name (a char *), giving the name of a field. The second string is comprised of the fields op_buflen and op_buf, used analogously. These two counted strings work in a “value-result” fashion. At entry to the ioctl, the counts are expected to reflect the buffer size; on return, the counts are updated to reflect the buffer contents.

The following ioctls are supported:

Takes nothing, and fills in the options node number.
OPIOCGETNEXT
Takes a node number and returns the number of the following node. The node following the last node is number 0; the node following number 0 is the first node.
Takes a node number and returns the number of the first “child” of that node. This child may have siblings; these can be discovered by using OPIOCGETNEXT.
Fills in the value of the named property for the given node. If no such property is associated with that node, the value length is set to -1. If the named property exists but has no value, the value length is set to 0.
Writes the given value under the given name. The OPENPROM may refuse this operation; in this case EINVAL is returned.
Finds the property whose name follows the given name in OPENPROM internal order. The resulting name is returned in the value field. If the named property is the last, the “next” name is the empty string. As with OPIOCGETNEXT, the next name after the empty string is the first name.

/dev/openprom

The following may result in rejection of an operation:

[]
The given node number is not zero and does not correspond to any valid node, or is zero where zero is not allowed.
[]
The requested operation requires permissions not specified at the call to open().
[]
The given name or value field exceeds the maximum allowed length (8191 bytes).

ioctl(2), eeprom(8)

A macppc openprom manual page first appeared in OpenBSD 4.3.

Due to limitations within the OPENPROM itself, these functions run at elevated priority and may adversely affect system performance.

September 15, 2013 OpenBSD-5.6