OpenBSD manual page server

Manual Page Search Parameters

MODLOAD(8) System Manager's Manual MODLOAD(8)

modloadload a kernel module

modload [-dnSsv] [-A kernel] [-e entry] [-o output_file] [-p postinstall] input_file

The modload utility loads a loadable kernel module into a running system. The input file is an object file (.o file).

The options to modload are as follows:

kernel
Specify the file that is passed to the linker to resolve module references to external symbols. The symbol file must be for the currently running kernel or the module is likely to crash the system.
Debug. Used to debug modload itself.
entry
Specify the module entry point. This is passed by modload to ld(1) when the module is linked. The default module entry point name is `xxxinit'. If `xxxinit' cannot be found, an attempt to use `<module_name>_lkmentry' will be made, where <module_name> is the filename being loaded without the `.o'.
Do everything, except calling the module entry point (and any post-install program).
output_file
Specify the name of the output file that is produced by the linker.
postinstall
Specify the name of a shell script or program that will be executed if the module is successfully loaded. It is always passed the module id (in decimal) and module type (in hexadecimal) as the first two arguments. For loadable drivers, the third argument is the block or character major device number. For a loadable system call, the third argument is the system call number.
Do not remove the temporary object file. By default, the ld(1) output is removed after being loaded into the kernel.
Do not load symbols from the kernel module.
Print comments about the loading process.

/dev/ksyms
Default file passed to the linker to resolve external references in the module.
/usr/include/sys/lkm.h
File containing definitions of module types.

The modload utility exits with a status of 0 on success and with a nonzero status if an error occurs.

ld(1), lkm(4), securelevel(7), modstat(8), modunload(8)

The modload command was designed to be similar in functionality to the corresponding command in SunOS 4.1.3.

Terrence R. Lambert <terry@cs.weber.edu>

July 16, 2013 OpenBSD-5.6