|LMC(4)||Device Drivers Manual||LMC(4)|
lmc — Lan Media
Corporation SSI/T1/DS1/HSSI/DS3 card device
lmc* at pci?
lmc driver provides support for the
Lan Media Corporation SSI, T1/DS1, HSSI, and DS3 PCI WAN adapters based on
the DEC 21140 Ethernet chip. The adapters use a DEC 21140 Ethernet chip for
the PCI bus interface. Leaving the bus interface chip, the data path goes
through a field programmable gate array, where HDLC processing is
accomplished. Leaving the FPGA, there are FIFO buffers and the DS1, DS3, and
V.35 drive circuitry.
The intent is to provide a synchronous serial link with HDLC framing at speeds of up to 10Mbps (for the SSI card), 52Mbps (for the HSSI card), BNC connectors for 45Mbps operation without a CSU/DSU (DS3 card), and an RJ45 jack for T1/E1 operation without a CSU/DSU (T1/DS1 card).
The card will automatically use HDLC framing and defaults to external clock source. For the DS1 and DS3 cards with built-in CSU/DSU functionality, the clock source is always external (from CSU/DSU). The ability to set cable length is not currently implemented.
Using the sppp(4)
driver, you can also use the ppp protocol. In either case, the
lmc interface should be configured as a
lmc device driver was written by
Michael Graff, and was derived in part from Matt Thomas'
de(4) driver. The
OpenBSD port and manual page are from Chris
Cappuccio. Later enhancements to support the LMC1200 card are based on LMC's
|June 2, 2013||OpenBSD-5.6|