OpenBSD manual page server

Manual Page Search Parameters

RWLOCK(9) Kernel Developer's Manual RWLOCK(9)

rwlock, rw_init, rw_enter, rw_exit, rw_enter_read, rw_enter_write, rw_exit_read, rw_exit_write, RWLOCK_INITIALIZERinterface to read/write locks

#include <sys/rwlock.h>

void
rw_init(struct rwlock *rwl, const char *name);

int
rw_enter(struct rwlock *rwl, int flags);

void
rw_exit(struct rwlock *rwl);

void
rw_enter_read(struct rwlock *rwl);

void
rw_enter_write(struct rwlock *rwl);

void
rw_exit_read(struct rwlock *rwl);

void
rw_exit_write(struct rwlock *rwl);

void
rw_assert_wrlock(struct rwlock *rwl);

void
rw_assert_rdlock(struct rwlock *rwl);

void
rw_assert_unlocked(struct rwlock *rwl);

RWLOCK_INITIALIZER(const char *name);

The rwlock set of functions provides a multiple-reader, single-writer locking mechanism to ensure mutual exclusion between different processes.

The () function is used to initiate the lock pointed to by rwl. The name argument specifies the name of the lock, which is used as the wait message if the process needs to sleep.

The () function acquires a lock. The flags argument specifies what kind of lock should be obtained and also modifies the operation. The possible flags are:

Acquire a shared lock.
Acquire an exclusive lock.
Safely release an exclusive lock and acquire a shared lock without letting other exclusive locks in between.
When waiting for a lock, allow signals to interrupt the sleep.
Do not wait for busy locks, fail with EBUSY instead.
Wait for busy locks, but do not obtain them, fail with EAGAIN instead.

The () function is used to release a held lock.

The () function acquires a read lock, sleeping if necessary.

The () function acquires a write lock, sleeping if necessary.

The () function releases a read lock.

The () function releases a write lock.

Read locks can be acquired while the write lock is not held, and may coexist in distinct processes at any time. A write lock, however, can only be acquired when there are no read locks held, granting exclusive access to a single process.

The (), (), and () functions check the status rwl, panicking if it is not write-, read-, or unlocked, respectively.

A lock declaration may be initialised with the () macro. The name argument specifies the name of the lock, which is used as the wait message if the process needs to sleep.

rw_init() can be called during autoconf, from process context, or from interrupt context.

rw_enter(), rw_exit(), rw_enter_read(), rw_enter_write(), rw_exit_read(), and rw_exit_write() can be called during autoconf or from process context.

lockmgr(9), mutex(9), spl(9)

The rwlock functions first appeared in OpenBSD 3.5.

The rwlock functions were written by Artur Grabowski <art@openbsd.org>.

February 14, 2014 OpenBSD-5.5