|RESOLV.CONF(5)||File Formats Manual||RESOLV.CONF(5)|
resolv.conf.tail — resolver
resolv.conf file specifies how the
resolver(3) routines in the
C library (which provide access to the Internet Domain Name System) should
operate. The resolver configuration file contains information that is read
by the resolver routines the first time they are invoked by a process. If
resolv.conf file does not exist, only the local
host file /etc/hosts will be consulted, i.e. the
Domain Name System will not be used to resolve hosts.
The file is designed to be human readable and contains a list of keywords with values that provide various types of resolver information. A resolv.conf file is not required for some setups, so this file is optional. It can be created manually, and is also created as part of the OpenBSD install process if use of the DHCP protocol is specified for any interface or if any DNS nameservers are configured.
If dhclient(8) is
used to configure the network it will normally overwrite the
resolv.conf file with updated information such as
nameserver addresses, losing any previous values the file contained. In
order to force options to be passed to the
resolver(3) routines, the
resolv.conf.tail may be created manually. This
file will be appended to the generated
file by dhclient, ensuring options remain. If no updated information is
available to dhclient, and
resolv.conf.tail is not
resolv.conf will not be modified by
On a machine whose network connection does not change frequently
(such as a desktop machine on a local-area network), the
resolv.conf.tail file should not be necessary.
resolv.conf.tail file may be useful on
notebooks, to search multiple domains, to refer to hard-coded information in
local files, or otherwise override the defaults.
A keyword and its values must appear on a single line, and the
nameserver) must start the line. The
value follows the keyword, separated by whitespace. A hash mark (#) or
semicolon (;) in the file indicates the beginning of a comment; subsequent
characters up to the end of the line are not interpreted by the routines
that read the file.
The configuration options (which may be placed in either file) are:
nameserver [10.0.0.1]:5353 nameserver [::1]:5353
MAXNS (currently 3) name servers
may be listed, one per line. If there are multiple servers, the resolver
library queries them in the order listed. If no
nameserver entries are present, the default is
to use the name server on the local machine. (The algorithm used is to
try a name server, and if the query times out, try the next, until out
of name servers, then repeat trying all name servers until a maximum
number of retries are performed.)
domainentry is present, the domain is determined from the local host name returned by gethostname(3) – the domain part is taken to be everything after the first dot. Finally, if the host name does not contain a domain part, the root domain is assumed.
lookup keyword is not used in
the system's resolv.conf file then the assumed
bind file. Furthermore, if the system's
resolv.conf file does not exist, then the only
database used is
searchkeyword with spaces or tabs separating the names. Most resolver queries will be attempted using each component of the search path in turn until a match is found. Note that this process may be slow and will generate a lot of network traffic if the servers for the listed domains are not local, and that queries will time out if no server is available for one of the domains.
The search list is currently limited to six domains with a
total of 1024 characters. Only one
should appear; if more than one is present, the last one found
overwrites any values found in earlier lines. So if such a line appears
resolv.conf.tail file, it should include
all the domains that need to be searched.
sortlistis specified by IP address netmask pairs. The netmask is optional and defaults to the natural netmask of the net. The IP address and optional network pairs are separated by slashes. Up to 10 pairs may be specified. For example:
sortlist 126.96.36.199/255.255.240.0 188.8.131.52
A maximum of two families can be specified, where family can be any of:
If only one family is specified, only that family is tried.
Where option is one of the following:
DEBUG. By default on OpenBSD this option does nothing.
nameserverlines are able to handle the extension.
To verify whether a server supports EDNS, query it using
the dig(1) query option
+edns=0: the reply indicates compliance
(EDNS version 0) and whether a UDP packet larger than 512 bytes can
be used. Note that EDNS0 can cause the server to send packets large
enough to require fragmentation. Other factors such as packet
filters may impede these, particularly if there is a reduced MTU, as
is often the case with
pppoe(4) or with
search keywords are mutually exclusive. If more than
one instance of these keywords is present, the last instance will
resolv.conf file format appeared in
|July 14, 2013||OpenBSD-5.5|