OpenBSD manual page server

Manual Page Search Parameters

RENICE(8) System Manager's Manual RENICE(8)

renicealter priority of running processes

renice -n increment [[-g] pgrp ...] [[-p] pid ...] [[-u] user ...]

renice alters the scheduling priority of one or more running processes by increment. Processes may be selected using the parameters pid (process ID), pgrp (process group ID), and user (user name or ID). If no flag is specified, the default is to select by process ID.

Users other than the superuser may only alter the priority of processes they own, and can only monotonically increase their “nice value” within the range 0 to PRIO_MAX (20). (This prevents overriding administrative fiats.) The superuser may alter the priority of any process and set the priority to any value in the range PRIO_MIN (-20) to PRIO_MAX.

Useful priorities are: 20 (the affected processes will run only when nothing else in the system wants to), 0 (the “base” scheduling priority), anything negative (to make things go very fast).

The options are as follows:

pgrp ...
Alter the scheduling priority of all processes in process group pgrp.
increment
A positive or negative decimal integer used to modify the scheduling priority.
pid ...
Alter the scheduling priority of process pid.
user ...
Alter the scheduling priority of all processes belonging to user, which may be a user name or ID.

/etc/passwd
for mapping user names to user IDs

The renice utility exits 0 on success, and >0 if an error occurs.

The following example changes the priority of process IDs 987 and 32, and all processes owned by users daemon and root:

# renice -n +1 987 -u daemon root -p 32

nice(1), getpriority(2), setpriority(2)

The renice utility is compliant with the IEEE Std 1003.1-2008 (“POSIX.1”) specification.

The historical behavior of passing the increment as the first argument is supported for backwards compatibility.

The arguments to flags [-gpu] are extensions to that specification.

The renice command appeared in 4.0BSD.

Non-superusers cannot increase scheduling priorities of their own processes, even if they were the ones that decreased the priorities in the first place.

September 29, 2010 OpenBSD-5.5