|TVRX(4)||Device Drivers Manual (hp300)||TVRX(4)|
tvrx — HP98705
PersonalVRX “TigerShark” frame buffer
tvrx* at dio?
wsdisplay* at tvrx?
The PersonalVRX frame buffer is an accelerated, high resolution (1280x1024) external display, connected to a 98702 DIO-II interface board. The external display is composed of one (66570) or two (66570 with 66571 option) 8-bit color frame buffer boards. Other option boards for the PersonalVRX family include the 66572 ‘Z-buffer’, the 66573 ‘Transform Engine and Scan’ board, and the 66574 ‘Colormap’. All models also have four overlay planes.
tvrx driver provides a frame buffer
abstraction to the wscons(4)
Currently, the driver can only use the overlay planes, and will run as an unaccelerated 16 color frame buffer.
2D acceleration is not available until the appropriate microcode has been downloaded into the framebuffer control logic; unfortunately, neither the microcode nor documentation about the download interface seem to be available.
The PersonalVRX devices can be configured using the 5 DIP switches selector on the interface board to define the “select code”. The select code value is computed by adding 133 to the number made from the five binary digits. The default settings, with the two MSB switches set to 1 and the three LSB switches set to 0, provide a select code of 157.
|January 18, 2013||OpenBSD-5.5|