|GBOX(4)||Device Drivers Manual (hp300)||GBOX(4)|
gbox — HP98700
Gatorbox frame buffer
gbox* at intio?
gbox* at dio?
wsdisplay* at gbox?
The HP98700 and HP98710 are 4-bit color frame buffers, also known as the Gatorbox. They can be extended to 8-bit color with an HP98701 frame buffer extension. The 98710 also has some acceleration features.
gbox driver provides a frame buffer
abstraction to the wscons(4)
The 98700 can be used as the only graphics device on a system, in which case it will be used as the system console. It can also be installed as a secondary display device. For the first case, the HP98287A M.A.D. interface card should be set to internal control space. This will put the frame buffer at the DIO address 0x200000 and the control registers at 0x560000. For use as a secondary device, the 98287A should be set to frame buffer address 0x300000, and to an external select code.
It should be noted that this configuration will conflict with the 98547 display card which has a 2 megabyte frame buffer starting at address 0x200000. The 98700 should only be installed as a secondary device in a machine with a 1 bit 98544 display card or 4 bit 98545 card. The 98700H Installation Guide contains further configuration information.
|March 26, 2008||OpenBSD-5.5|