OpenBSD manual page server

Manual Page Search Parameters

DOMOUNTROOTHOOKS(9) Kernel Developer's Manual DOMOUNTROOTHOOKS(9)

domountroothooksrun all mountroot hooks

#include <sys/types.h>
#include <sys/systm.h>

void
domountroothooks(void);

The () function invokes all mountroot hooks established using the mountroothook_establish(9) function. Mountroot hooks are called in order, i.e., the mountroot hook established first will be called first.

This function is called from () with interrupts turned on. It is called immediately before the system configures its root and swap devices, but fully after all normal autoconfiguration. This can be used to let device subsystems needing delayed configuration (e.g., due to very long initialization times) still provide the root device.

Mountroot hooks are, like shutdown hooks, implemented via the more general dohooks(9) API.

dohooks(9), doshutdownhooks(9), mountroothook_establish(9)

November 5, 2013 OpenBSD-5.5