|DHCLIENT.LEASES(5)||File Formats Manual||DHCLIENT.LEASES(5)|
DHCP client lease database
dhclient(8) keeps a persistent database of leases that it has acquired that are still valid. The database is a free-form ASCII file containing one valid declaration per lease. The file is written as a log, so the last declaration is the most recent lease obtained.
The lease file is named /var/db/dhclient.leases.⟨IFNAME⟩, where "IFNAME" represents the network interface dhclient(8) acquired the lease on. For example, if dhclient(8) is configured for the em0 network device, the lease file will be named /var/db/dhclient.leases.em0,
The format of the lease declarations is described in dhclient.conf(5).
R. Droms, Dynamic Host Configuration Protocol, RFC 2131, March 1997.
S. Alexander and R. Droms, DHCP Options and BOOTP Vendor Extensions, RFC 2132, March 1997.
The current implementation was reworked by Henning Brauer <email@example.com>.
|July 16, 2013||OpenBSD-5.5|