|BOOT_ZAURUS(8)||System Manager's Manual (zaurus)||BOOT_ZAURUS(8)|
zaurus system bootstrapping procedures
When powered on, or if the system is rebooted via reboot(8) or shutdown(8), the processor begins executing code at physical address 0. The early startup code is preinstalled by the manufacturer, and will load a minimal UNIX-like operating system from internal flash memory (our primary bootstrap loader, for now).
On most systems, booting OpenBSD from the primary bootstrap loader will eventually load the OpenBSD-specific zaurus bootstrapping code. This versatile program is described in a separate document, boot(8).
In case of system crashes, the kernel will usually enter the kernel debugger, ddb(4), unless it is not present in the kernel, or it is disabled via the ddb.panic sysctl. Upon leaving ddb, or if ddb was not entered, the kernel will halt the system if it was still in device configuration phase, or attempt a dump to the configured dump device, if possible. The crash dump will then be recovered by savecore(8) during the next multi-user boot cycle. It is also possible to force other behaviours from ddb.
|May 31, 2007||OpenBSD-5.5|