|SYSLOGD(8)||System Manager's Manual||SYSLOGD(8)|
syslogdreads and logs messages to the system console, log files, pipes to other programs, other machines and/or users as specified by its configuration file. The options are as follows:
syslogdshould place an additional log socket. Up to about 20 additional logging sockets can be specified. The primary use for this is to place additional log sockets in /dev/log of various chroot filespaces.
-uoption on a loghost with no DNS cache. Messages from the local host will still be logged with the symbolic local host name.
AF_LOCALsocket for use in reporting logs stored in memory buffers using syslogc(8).
syslogdreads its configuration file when it starts up and whenever it receives a hangup signal. For information on the format of the configuration file, see syslog.conf(5).
syslogdcreates the file /var/run/syslog.pid, and stores its process ID there. This can be used to kill or reconfigure
syslogdopens an Internet domain socket as specified in /etc/services. Normally
syslogdwill only use this socket to send messages outwards, but in “insecure” mode it will also read messages from this socket.
syslogdalso opens and reads messages from the UNIX-domain socket /dev/log, and from the special device /dev/klog (to read kernel messages).
syslogdopens the above described socket whether or not it is running in secure mode. If
syslogdis running in secure mode, all incoming data on this socket is discarded. The socket is required for sending forwarded messages. The message sent to
syslogdshould consist of a single line. The message can contain a priority code, which should be a preceding decimal number in angle braces, for example, “⟨5⟩”. This priority code should map into the priorities defined in the include file ⟨sys/syslog.h⟩.
syslogdcommand appeared in 4.3BSD.
syslogddoes not create files, it only logs to existing ones.
|February 10, 2013||OpenBSD-5.4|