OpenBSD manual page server

Manual Page Search Parameters

VHOLD(9) Kernel Developer's Manual VHOLD(9)

vholdacquire a hold on a vnode

#include <sys/param.h>
#include <sys/vnode.h>

void
vhold(struct vnode *vp);

The () function increments the v_holdcnt of the given vnode. If the vnode has already been added to the free list and its v_holdcnt and v_usecount are both zero, it will be removed from the free list and added to the vnode hold list.

vnode(9)

This man page was originally written by Chad David ⟨davidc@acns.ab.ca⟩ for FreeBSD.

December 15, 2009 OpenBSD-5.1