|USERDEL(8)||System Manager's Manual||USERDEL(8)|
userdelutility removes a user from the system, optionally removing that user's home directory and any subdirectories.
Default values are taken from the information provided in the /etc/usermgmt.conf file, which, if running as root, is created using the built-in defaults if it does not exist.
The first form of the command shown above (using the
-D option) sets and displays the defaults for the
-Dwill show the current defaults which will be used by the
userdelutility. Together with one of the options shown for the first version of the command,
-Dwill set the default to be the new value.
yes’, or a non-zero number, then the user login information will be preserved.
In the second form of the command, after setting any defaults, and then reading values from /etc/usermgmt.conf, the following command line options are processed:
preserve’ field. If the field has any of the values ‘
yes’, or a non-zero number, then user information preservation will take place.
Once the information has been verified,
pwd_mkdb(8) to update the
user database. This is run in the background, and, at very large sites could
take several minutes. Until this update is completed, the password file is
unavailable for other updates and the new information is not available to
userdelutility exits 0 on success, and >0 if an error occurs. passwd(5), usermgmt.conf(5), nologin(8), pwd_mkdb(8)
userdelutility first appeared in OpenBSD 2.7.
userdelutility was written by Alistair G. Crooks ⟨agc@NetBSD.org⟩.
|December 24, 2011||OpenBSD-5.1|