|SSHD(8)||System Manager's Manual||SSHD(8)|
sshd — OpenSSH SSH
sshd (OpenSSH Daemon) is the daemon
program for ssh(1). Together
these programs replace
rsh(1), and provide secure
encrypted communications between two untrusted hosts over an insecure
sshd listens for connections from clients.
It is normally started at boot from /etc/rc. It
forks a new daemon for each incoming connection. The forked daemons handle
key exchange, encryption, authentication, command execution, and data
sshd can be configured using command-line
options or a configuration file (by default
command-line options override values specified in the configuration file.
sshd rereads its configuration file when it receives
a hangup signal,
SIGHUP, by executing itself with
the name and options it was started with, e.g.
The options are as follows:
sshdto use IPv4 addresses only.
sshdto use IPv6 addresses only.
-Textended test mode. If provided, any
Matchdirectives in the configuration file that would apply to the specified user, host, and address will be set before the configuration is written to standard output. The connection parameters are supplied as keyword=value pairs. The keywords are “user”, “host”, and “addr”. All are required and may be supplied in any order, either with multiple
-Coptions or as a comma-separated list.
sshdduring key exchange. The certificate file must match a host key file specified using the
-hoption or the
sshdwill not detach and does not become a daemon. This allows easy monitoring of
-doptions increase the debugging level. Maximum is 3.
sshdwill send the output to the standard error instead of the system log.
sshdrefuses to start if there is no configuration file.
sshdis not run as root (as the normal host key files are normally not readable by anyone but root). The default is /etc/ssh/ssh_host_key for protocol version 1, and /etc/ssh/ssh_host_dsa_key, /etc/ssh/ssh_host_ecdsa_key and /etc/ssh/ssh_host_rsa_key for protocol version 2. It is possible to have multiple host key files for the different protocol versions and host key algorithms.
sshdis being run from inetd(8).
sshdis normally not run from inetd because it needs to generate the server key before it can respond to the client, and this may take tens of seconds. Clients would have to wait too long if the key was regenerated every time. However, with small key sizes (e.g. 512) using
sshdfrom inetd may be feasible.
Portoption are ignored when a command-line port is specified. Ports specified using the
ListenAddressoption override command-line ports.
Matchrules may be applied by specifying the connection parameters using one or more
sshdreliably as configuration options may change.
utmpstructure that holds the remote host name. If the resolved host name is longer than len, the dotted decimal value will be used instead. This allows hosts with very long host names that overflow this field to still be uniquely identified. Specifying
-u0indicates that only dotted decimal addresses should be put into the utmp file.
-u0may also be used to prevent
sshdfrom making DNS requests unless the authentication mechanism or configuration requires it. Authentication mechanisms that may require DNS include
HostbasedAuthentication, and using a
from="pattern-list"option in a key file. Configuration options that require DNS include using a USER@HOST pattern in
The OpenSSH SSH daemon supports SSH protocols 1 and 2. The default
is to use protocol 2 only, though this can be changed via the
Protocol option in
2 supports DSA, ECDSA and RSA keys; protocol 1 only supports RSA keys. For
both protocols, each host has a host-specific key, normally 2048 bits, used
to identify the host.
Forward security for protocol 1 is provided through an additional server key, normally 768 bits, generated when the server starts. This key is normally regenerated every hour if it has been used, and is never stored on disk. Whenever a client connects, the daemon responds with its public host and server keys. The client compares the RSA host key against its own database to verify that it has not changed. The client then generates a 256-bit random number. It encrypts this random number using both the host key and the server key, and sends the encrypted number to the server. Both sides then use this random number as a session key which is used to encrypt all further communications in the session. The rest of the session is encrypted using a conventional cipher, currently Blowfish or 3DES, with 3DES being used by default. The client selects the encryption algorithm to use from those offered by the server.
For protocol 2, forward security is provided through a Diffie-Hellman key agreement. This key agreement results in a shared session key. The rest of the session is encrypted using a symmetric cipher, currently 128-bit AES, Blowfish, 3DES, CAST128, Arcfour, 192-bit AES, or 256-bit AES. The client selects the encryption algorithm to use from those offered by the server. Additionally, session integrity is provided through a cryptographic message authentication code (hmac-md5, hmac-sha1, umac-64, hmac-ripemd160, hmac-sha2-256 or hmac-sha2-512).
Finally, the server and the client enter an authentication dialog. The client tries to authenticate itself using host-based authentication, public key authentication, challenge-response authentication, or password authentication.
If the client successfully authenticates itself, a dialog for preparing the session is entered. At this time the client may request things like allocating a pseudo-tty, forwarding X11 connections, forwarding TCP connections, or forwarding the authentication agent connection over the secure channel.
After this, the client either requests a shell or execution of a command. The sides then enter session mode. In this mode, either side may send data at any time, and such data is forwarded to/from the shell or command on the server side, and the user terminal in the client side.
When the user program terminates and all forwarded X11 and other connections have been closed, the server sends command exit status to the client, and both sides exit.
When a user successfully logs in,
does the following:
PermitUserEnvironmentoption in sshd_config(5).
If the file ~/.ssh/rc exists,
sh(1) runs it after reading the
environment files but before starting the user's shell or command. It must
not produce any output on stdout; stderr must be used instead. If X11
forwarding is in use, it will receive the "proto cookie" pair in
its standard input (and
DISPLAY in its environment).
The script must call xauth(1)
sshd will not run xauth automatically to add
The primary purpose of this file is to run any initialization routines which may be needed before the user's home directory becomes accessible; AFS is a particular example of such an environment.
This file will probably contain some initialization code followed by something similar to:
if read proto cookie && [ -n "$DISPLAY" ]; then if [ `echo $DISPLAY | cut -c1-10` = 'localhost:' ]; then # X11UseLocalhost=yes echo add unix:`echo $DISPLAY | cut -c11-` $proto $cookie else # X11UseLocalhost=no echo add $DISPLAY $proto $cookie fi | xauth -q - fi
If this file does not exist, /etc/ssh/sshrc is run, and if that does not exist either, xauth is used to add the cookie.
AuthorizedKeysFile specifies the files
containing public keys for public key authentication; if none is specified,
the default is ~/.ssh/authorized_keys and
~/.ssh/authorized_keys2. Each line of the file
contains one key (empty lines and lines starting with a
#’ are ignored as comments). Protocol
1 public keys consist of the following space-separated fields: options,
bits, exponent, modulus, comment. Protocol 2 public key consist of: options,
keytype, base64-encoded key, comment. The options field is optional; its
presence is determined by whether the line starts with a number or not (the
options field never starts with a number). The bits, exponent, modulus, and
comment fields give the RSA key for protocol version 1; the comment field is
not used for anything (but may be convenient for the user to identify the
key). For protocol version 2 the keytype is
“ecdsa-sha2-nistp521”, “ssh-dss” or
Note that lines in this file are usually several hundred bytes long (because of the size of the public key encoding) up to a limit of 8 kilobytes, which permits DSA keys up to 8 kilobits and RSA keys up to 16 kilobits. You don't want to type them in; instead, copy the identity.pub, id_dsa.pub, id_ecdsa.pub, or the id_rsa.pub file and edit it.
sshd enforces a minimum RSA key modulus
size for protocol 1 and protocol 2 keys of 768 bits.
The options (if present) consist of comma-separated option specifications. No spaces are permitted, except within double quotes. The following option specifications are supported (note that option keywords are case-insensitive):
Certificates may encode access restrictions similar to these key options. If both certificate restrictions and key options are present, the most restrictive union of the two is applied.
no-pty. A quote may be included in the command by quoting it with a backslash. This option might be useful to restrict certain public keys to perform just a specific operation. An example might be a key that permits remote backups but nothing else. Note that the client may specify TCP and/or X11 forwarding unless they are explicitly prohibited. The command originally supplied by the client is available in the
SSH_ORIGINAL_COMMANDenvironment variable. Note that this option applies to shell, command or subsystem execution. Also note that this command may be superseded by either a sshd_config(5)
ForceCommanddirective or a command embedded in a certificate.
PermitUserEnvironmentoption. This option is automatically disabled if
In addition to the wildcard matching that may be applied to
hostnames or addresses, a
from stanza may match
IP addresses using CIDR address/masklen notation.
The purpose of this option is to optionally increase security: public key authentication by itself does not trust the network or name servers or anything (but the key); however, if somebody somehow steals the key, the key permits an intruder to log in from anywhere in the world. This additional option makes using a stolen key more difficult (name servers and/or routers would have to be compromised in addition to just the key).
``ssh -L''port forwarding such that it may only connect to the specified host and port. IPv6 addresses can be specified by enclosing the address in square brackets. Multiple
permitopenoptions may be applied separated by commas. No pattern matching is performed on the specified hostnames, they must be literal domains or addresses. A port specification of
*matches any port.
cert-authorityline, specifies allowed principals for certificate authentication as a comma-separated list. At least one name from the list must appear in the certificate's list of principals for the certificate to be accepted. This option is ignored for keys that are not marked as trusted certificate signers using the
An example authorized_keys file:
# Comments allowed at start of line ssh-rsa AAAAB3Nza...LiPk== firstname.lastname@example.org from="*.sales.example.net,!pc.sales.example.net" ssh-rsa AAAAB2...19Q== email@example.com command="dump /home",no-pty,no-port-forwarding ssh-dss AAAAC3...51R== example.net permitopen="192.0.2.1:80",permitopen="192.0.2.2:25" ssh-dss AAAAB5...21S== tunnel="0",command="sh /etc/netstart tun0" ssh-rsa AAAA...== firstname.lastname@example.org
The /etc/ssh/ssh_known_hosts and ~/.ssh/known_hosts files contain host public keys for all known hosts. The global file should be prepared by the administrator (optional), and the per-user file is maintained automatically: whenever the user connects from an unknown host, its key is added to the per-user file.
Each line in these files contains the following fields: markers (optional), hostnames, bits, exponent, modulus, comment. The fields are separated by spaces.
The marker is optional, but if it is present then it must be one of “@cert-authority”, to indicate that the line contains a certification authority (CA) key, or “@revoked”, to indicate that the key contained on the line is revoked and must not ever be accepted. Only one marker should be used on a key line.
Hostnames is a comma-separated list of patterns
?’ act as wildcards); each pattern in
turn is matched against the canonical host name (when authenticating a
client) or against the user-supplied name (when authenticating a server). A
pattern may also be preceded by ‘
indicate negation: if the host name matches a negated pattern, it is not
accepted (by that line) even if it matched another pattern on the line. A
hostname or address may optionally be enclosed within
]’ brackets then followed by
:’ and a non-standard port
Alternately, hostnames may be stored in a hashed form which hides
host names and addresses should the file's contents be disclosed. Hashed
hostnames start with a ‘
Only one hashed hostname may appear on a single line and none of the above
negation or wildcard operators may be applied.
Bits, exponent, and modulus are taken directly from the RSA host key; they can be obtained, for example, from /etc/ssh/ssh_host_key.pub. The optional comment field continues to the end of the line, and is not used.
Lines starting with ‘
empty lines are ignored as comments.
When performing host authentication, authentication is accepted if any matching line has the proper key; either one that matches exactly or, if the server has presented a certificate for authentication, the key of the certification authority that signed the certificate. For a key to be trusted as a certification authority, it must use the “@cert-authority” marker described above.
The known hosts file also provides a facility to mark keys as revoked, for example when it is known that the associated private key has been stolen. Revoked keys are specified by including the “@revoked” marker at the beginning of the key line, and are never accepted for authentication or as certification authorities, but instead will produce a warning from ssh(1) when they are encountered.
It is permissible (but not recommended) to have several lines or different host keys for the same names. This will inevitably happen when short forms of host names from different domains are put in the file. It is possible that the files contain conflicting information; authentication is accepted if valid information can be found from either file.
Note that the lines in these files are typically hundreds of characters long, and you definitely don't want to type in the host keys by hand. Rather, generate them by a script, ssh-keyscan(1) or by taking /etc/ssh/ssh_host_key.pub and adding the host names at the front. ssh-keygen(1) also offers some basic automated editing for ~/.ssh/known_hosts including removing hosts matching a host name and converting all host names to their hashed representations.
An example ssh_known_hosts file:
# Comments allowed at start of line closenet,...,192.0.2.53 1024 37 159...93 closenet.example.net cvs.example.net,192.0.2.10 ssh-rsa AAAA1234.....= # A hashed hostname |1|JfKTdBh7rNbXkVAQCRp4OQoPfmI=|USECr3SWf1JUPsms5AqfD5QfxkM= ssh-rsa AAAA1234.....= # A revoked key @revoked * ssh-rsa AAAAB5W... # A CA key, accepted for any host in *.mydomain.com or *.mydomain.org @cert-authority *.mydomain.org,*.mydomain.com ssh-rsa AAAAB5W...
PrintMotd, respectively, are enabled. It does not suppress printing of the banner specified by
sshdreads it as root. Additionally, this file must be owned by the user, and must not have write permissions for anyone else. The recommended permission for most machines is read/write for the user, and not accessible by others.
If this file, the ~/.ssh directory, or
the user's home directory are writable by other users, then the file
could be modified or replaced by unauthorized users. In this case,
sshd will not allow it to be used unless the
StrictModes option has been set to
#’), and assignment lines of the form name=value. The file should be writable only by the user; it need not be readable by anyone else. Environment processing is disabled by default and is controlled via the
sshdrefuses to let anyone except root log in. The contents of the file are displayed to anyone trying to log in, and non-root connections are refused. The file should be world-readable.
sshddoes not start if these files are group/world-accessible.
sshd. The file format and configuration options are described in sshd_config(5).
sshdduring privilege separation in the pre-authentication phase. The directory should not contain any files and must be owned by root and not group or world-writable.
sshdlistening for connections (if there are several daemons running concurrently for different ports, this contains the process ID of the one started last). The content of this file is not sensitive; it can be world-readable.
OpenSSH is a derivative of the original and free ssh 1.2.12 release by Tatu Ylonen. Aaron Campbell, Bob Beck, Markus Friedl, Niels Provos, Theo de Raadt and Dug Song removed many bugs, re-added newer features and created OpenSSH. Markus Friedl contributed the support for SSH protocol versions 1.5 and 2.0. Niels Provos and Markus Friedl contributed support for privilege separation.
|September 23, 2011||OpenBSD-5.1|