|INSTALLBOOT(8)||System Manager's Manual (sparc64)||INSTALLBOOT(8)|
installbootprepares an FFS filesystem partition for boot-strapping from the PROM. The sparc64 boot process is split into two parts: a small first-stage bootblock that is written into the superblock area of a partition (and hence is limited in size to SBSIZE - DEV_BSIZE bytes), and a second-stage boot program that resides in the filesystem proper. The first-stage bootblock is loaded into memory by the PROM. After it receives control, it loads the second-stage boot program ofwboot from the filesystem. The second-stage boot program uses the device driver interface to the PROM and the stand-alone filesystem code in “libsa.a” to locate and load the kernel. The first-stage bootblock and second-stage boot program can be found in /usr/mdec/bootblk and /usr/mdec/ofwboot respectively. The second-stage boot program commonly resides in the root directory as /ofwboot.
The options are as follows:
The arguments are:
# cp /usr/mdec/ofwboot /ofwboot # /usr/mdec/installboot /usr/mdec/bootblk sd0a
installbootfirst appeared in NetBSD 1.1.
|January 1, 2012||OpenBSD-5.1|