OpenBSD manual page server

Manual Page Search Parameters

PSIGNAL(9) Kernel Developer's Manual PSIGNAL(9)

psignal, pgsignal, gsignalpost signal to a process

void
psignal(struct proc *p, int signum);

void
pgsignal(struct pgrp *pgrp, int signum, int checkctty);

void
gsignal(int pgid, int signum);

These functions post a signal to one or more processes. The argument signum common to all three functions should be in the range [1-NSIG].

The () function posts signal number signum to the process represented by the process structure p. With a few exceptions noted below, the target process signal disposition is updated and is marked as runnable, so further handling of the signal is done in the context of the target process after a context switch. Note that psignal() does not by itself cause a context switch to happen.

The target process is not marked as runnable in the following cases:

If the target process is being traced, () behaves as if the target process were taking the default action for signum. This allows the tracing process to be notified of the signal.

The () function posts signal number signum to each member of the process group described by pgrp. If checkctty is non-zero, the signal will be posted only to processes that have a controlling terminal. If pgrp is NULL no action is taken.

The () function posts signal number signum to each member of the process group identified by the group id pgid. If pgid is zero no action is taken.

These functions are implemented in the file sys/kern/kern_sig.c.

sigaction(2), tsleep(9)

June 26, 2008 OpenBSD-5.1