|MAILQ(8)||System Manager's Manual||MAILQ(8)|
mailqprints a summary of the mail messages queued for future delivery. It may only be run by the superuser.
The first line printed for each message shows the internal identifier used on this host for the message with a possible status character, the size of the message in bytes, the date and time the message was accepted into the queue, and the envelope sender of the message. The second line shows the error message that caused this message to be retained in the queue; it will not be present if the message is being processed for the first time. The status characters are either ‘*’ to indicate the job is being processed; ‘X’ to indicate that the load is too high to process the job; and ‘-’ to indicate that the job is too young to process. The following lines show message recipients, one per line.
mailq is identical to
The options are as follows:
Several sendmail.cf options influence the behavior of the
mailq utility. The number of items printed per queue
group is restricted by
MaxQueueRunSize if that value
is set. The status character ‘*’ is not printed for some
modification, and none, unless a
-q option is used to limit the processed jobs.
mailqutility exits 0 on success, and >0 if an error occurs. mailer.conf(5), sendmail(8)
mailqcommand appeared in 4.0BSD.
|September 23, 2010||OpenBSD-5.1|