|LOGIN_KERBEROS(8)||System Manager's Manual||LOGIN_KERBEROS(8)|
login_krb5utility implements the KerberosV authentication mechanism. It is called by login(1), su(1), ftpd(8), and others to authenticate the user with KerberosV.
The user argument is the user's name to be authenticated.
The service argument specifies which protocol to use with the invoking program. The allowed protocols are login, challenge, and response. (The challenge protocol is silently ignored but will report success as KerberosV authentication is not challenge-response based).
If invokinguser is set and the user argument is root, the principal invokinguser/root will be used for authentication.
If the notickets argument is equal to “no”, the default value, and the login argument is equal to “yes”, then the ticket will be saved in a credentials cache.
The class argument is ignored for compatibility with other login scripts.
login_krb5 will prompt the user for a
password and report back to the invoking program whether or not the
authentication was successful.
|February 1, 2012||OpenBSD-5.1|