|IKED(8)||System Manager's Manual||IKED(8)|
ikedis an Internet Key Exchange (IKEv2) daemon which performs mutual authentication and which establishes and maintains IPsec flows and security associations (SAs) between the two peers.
The IKEv2 protocol is defined in RFC 5996, which combines and
updates the previous standards: ISAKMP/Oakley (RFC 2408), IKE (RFC 2409),
and the Internet DOI (RFC 2407).
iked only supports
the IKEv2 protocol; support for ISAKMP/Oakley and IKEv1 is provided by
iked supports mutual authentication using
RSA public keys and X.509 certificates. See the
FILES section below and
CERTIFICATE AUTHORITY COMMANDS in
ikectl(8) for more
information about creating and maintaining the public key
The options are as follows:
ikedin passive mode. See the
set passiveoption in iked.conf(5) for more information.
Internet Key Exchange Protocol Version 2 (IKEv2), RFC 5996, September 2010.
ikedprogram first appeared in OpenBSD 4.8.
ikedprogram was written by Reyk Floeter ⟨email@example.com⟩.
ikedis not yet finished and is missing some important security features. It should not yet be used in production networks.
|December 22, 2010||OpenBSD-5.1|