|INSTALLBOOT(8)||System Manager's Manual (i386)||INSTALLBOOT(8)|
installbootis used to install a “first-stage” boot program into the boot area of an FFS disk partition. It inserts the block number and offset of the inode of the second-stage boot program boot(8) so that the biosboot(8) program can load it. Various filesystem parameters are also patched into the boot block.
The options are as follows:
The arguments are:
The ‘c’ partition is always used to represent the “entire” disk on i386.
# cp /usr/mdec/boot /boot # /usr/mdec/installboot -n -v /boot /usr/mdec/biosboot sd0
And if the information supplied looks right, run the above without
-n flag. If you are upgrading an old system, you
may need to perform some additional steps first. For example:
boot the floppy.fs filesystem floppy # fsck /dev/rsd0a # mount /dev/sd0a /mnt # cp /usr/mdec/boot /mnt/boot # /usr/mdec/installboot -v /mnt/boot /usr/mdec/biosboot sd0
/boot must be on the drive/partition
specified by disk; you cannot perform cross-device
|March 6, 2010||OpenBSD-5.1|