|HTTPD(8)||System Manager's Manual||HTTPD(8)|
httpd — Apache
HyperText Transfer Protocol server
httpd is the Apache HyperText Transfer
Protocol (HTTP) server program. It is designed to be run as a stand-alone
daemon process. When used like this it will create a pool of child processes
to handle requests. To stop it, send a
to the initial (parent) process. The PID of this process is written to a
file as given in the configuration file. Normally this service can be
enabled for startup on OpenBSD by editing
httpd may be invoked by the
Internet daemon inetd(8) each
time a connection to the HTTP service is made.
httpd can be made to support HTTPS
transactions if RSA certificates are generated and the utility is started
with the -DSSL flag. See
ssl(8) for further
chroot(2) to the
“ServerRoot” path, serving documents from the
“DocumentRoot” path. As a result of the default secure
httpd cannot access any objects outside
“ServerRoot” - this security measure is taken in case
httpd is compromised. This is not without drawbacks,
CGI programs may fail due to the limited environment available inside this chroot space. “UserDir”, of course, cannot access files outside the directory space. Other modules will also have issues. “DocumentRoot” directories or any other files needed must be inside “ServerRoot”. For this to work, pathnames inside the configuration file do not need adjustment relative to “ServerRoot”. For this option to remain secure, it is important that no files or directories writable by user www or group www are created inside the “ServerRoot”.
-u option (see below) can be specified
to disable chroot(2)
This manual page only lists the command line arguments. For
details of the directives necessary to configure
httpd, see the Apache manual in
/usr/share/doc/html/httpd/. Paths in this manual
page reflect those compiled into
httpd by default
The options are as follows:
-U, this can be used to remove ambiguities in cases such as "BindAddress *".
httpdwas built with the
SHARED_CORErule enabled which forces the
httpdcore code to be placed into a dynamic shared object (DSO) file. This file is searched in a hardcoded path under ServerRoot per default. Use this option to override.
httpdwill chroot(2) to the “ServerRoot” path. The
-uoption disables this behaviour, and returns
httpdto the expanded "unsecure" behaviour.
httpd, and then exit.
httpd, and then exit.
The documents served by
httpd should not
be owned by the user which
httpd is running as
(usually user www and group
www). They must, however, be readable by this
The Apache manual: /usr/share/doc/html/httpd/.
|May 18, 2010||OpenBSD-5.1|