|FSCK_EXT2FS(8)||System Manager's Manual||FSCK_EXT2FS(8)|
Second Extended File System consistency check and
fsck_ext2fs performs interactive file
system consistency checks and repairs for each of the file systems
specified. It is normally invoked from
The kernel takes care that only a restricted class of innocuous file system inconsistencies can happen unless hardware or software failures intervene. These are limited to the following:
These are the only inconsistencies that
fsck_ext2fs in “preen” mode (with the
-p option) will correct; if it encounters other
inconsistencies, it exits with an abnormal return status. For each corrected
inconsistency one or more lines will be printed identifying the file system
on which the correction will take place, and the nature of the correction.
After successfully correcting a file system,
fsck_ext2fs will print the number of files on that
file system and the number of used and free blocks.
If sent a
fsck_ext2fs will finish the file system checks, then
exit with an abnormal return status.
fsck_ext2fs audits and interactively repairs
inconsistent conditions for file systems. If the file system is
inconsistent, the operator is prompted for concurrence before each
correction is attempted. It should be noted that some of the corrective
actions which are not correctable under the
option will result in some loss of data. The amount and severity of data
lost may be determined from the diagnostic output. The default action for
each consistency correction is to wait for the operator to respond
“yes” or “no”. If the operator does not have
write permission on the file system,
will default to a
The following flags are interpreted by
fsck_ext2fswill not check the file system. This option forces
fsck_ext2fsto check the file system, regardless of the state of the clean flag.
fsck_ext2fsexcept for “CONTINUE?”, which is assumed to be affirmative. File systems will not be opened for writing. This is the default for file systems to be checked that are concurrently mounted writable.
fsck_ext2fs; this should be used with great caution as this is a free license to continue after essentially unlimited trouble has been encountered.
Inconsistencies checked are as follows:
Orphaned files and directories (allocated but unreferenced) are, with the operator's concurrence, reconnected by placing them in the lost+found directory. The name assigned is the inode number. If the lost+found directory does not exist, it is created. If there is insufficient space its size is increased.
Because of inconsistencies between the block device and the buffer cache, the raw device should always be used.
The diagnostics produced by
are fully enumerated and explained in Appendix A of
Fsck_ffs - The UNIX File System Check
|January 10, 2010||OpenBSD-5.1|