|DHCP(8)||System Manager's Manual||DHCP(8)|
dhcp — configuring
OpenBSD for DHCP
The Dynamic Host Configuration Protocol (DHCP) allows hosts on a TCP/IP network to configure one or more network interfaces based on information collected from a DHCP server in response to a DHCP request. This mechanism is often used, for example, by cable modem and DSL network providers to simplify network configurations for their clients/customers.
Information typically contained within a DHCP response includes an IP address for the interface, subnet mask, broadcast address, router (gateway) listing, domain name server listing, and the interface's MTU.
To set up OpenBSD as a DHCP client:
The /etc/netstart script reads each of these hostname files at boot-time and runs the dhclient(8) program for each interface that is to be configured via DHCP.
To set up OpenBSD as a DHCP server:
dhcpd_flags="". This will cause OpenBSD to start the dhcpd(8) daemon at boot-time and listen for DHCP requests on the local network. To start it manually, execute the following command:
# /usr/sbin/dhcpd [netif1 netif2 ...]
The DHCP client and server use the Berkeley Packet Filter (BPF). Ensure the kernel has been compiled with BPF support and at least one /dev/bpf* file exists per broadcast network interface that is attached to the system. This is almost always the case and should only be considered if all other troubleshooting options have failed.
See dhcpd(8) for information on other available options. Note, however, that most of the flags are useful only for debugging purposes.
dhcpd_flagsmust be set
|June 8, 2008||OpenBSD-5.1|