|BOOT(8)||System Manager's Manual (amd64)||BOOT(8)|
As described in boot_amd64(8), this program is loaded by the biosboot(8) primary bootstrap loader and provides a convenient way to load the kernel. This program acts as an enhanced boot monitor for PC systems, providing a common interface for the kernel to start from.
Basic operations include:
The sequence of its operation is as follows: initialization,
parsing the configuration file, then an interactive command line. While at
the command line you have 5 seconds to type any commands, if needed. If time
expires, the kernel will be loaded according to the current variable
settings (see the
set command). Each time a kernel
load fails, the timeout is increased by one second. The sequence of
boot operations is as follows:
pc0) and up to four serial consoles (
com3) connected to the serial ports. Display messages to the default console about the devices found.
bootwas loaded from, open and parse it. This file may contain any commands
bootaccepts at the interactive prompt. Though default settings usually suffice, they can be changed here.
boot.conf processing can be skipped,
and the automatic boot cancelled, by holding down either Control key as
>> OpenBSD/amd64 BOOT [x.xx]
is displayed to the active console, where
x.xx is the version number of the
boot program, followed by the
prompt, which means you are in interactive mode and may enter
commands. If you do not,
boot will proceed to
load the kernel with the current parameters after the timeout period has
boot attempts to load the
kernel executable /bsd. If it fails to find the
kernel and no alternative kernel image has been specified, the system will
be unable to boot.
bootvariables will be used.
When selecting the device to boot from,
boot makes no distinction between SCSI and IDE
type drives; they are detected as ‘hd’ devices. Therefore,
to boot kernel /bsd from slice ‘a’
on the first hard drive (irrespective of device type), specify
Meaning to add(+), exempt(-) or limit(=) the amount of memory specified by <size> at the location specified by <address>. Both size and base address can be specified as octal, decimal, or hexadecimal numbers, as accepted by the strtoul(3) routine.
The limit(=) option simply ignores any memory above the given memory limit. This is useful for testing kernels in an artificially constrained memory situation. For example, the following limits the kernel to using only memory below 64M:
machine mem =64M
Memory segments are not required to be adjacent to each other; the only requirement is that there is real physical memory under the range added. The following example adds 32M of memory right after the first 16M:
machine mem +0x2000000@0x1000000
Another useful command is to withdraw a range of memory from OS usage (it may have been wrongfully reported as useful by the BIOS). This example effectively excludes the 15–16M range from the map of useful memory:
machine mem -0x100000@0xf00000
bootwas compiled with DEBUG defined.
pc0). Currently, only the first serial port (
com0) is supported for console on amd64.
bootoffers you five seconds of grace time before committing the change to allow you to change your terminal's speed to match. If changing speed not for the active console, the baudrate is set for the next time you switch to a serial console. The baudrate value is not used for the
The default baudrate is 9600bps.
Remove the 5 second pause at boot-time permanently, causing
boot to load the kernel immediately without
# echo "boot" > /etc/boot.conf
Use serial console. A null modem cable should connect the specified serial port to a terminal. Useful for debugging.
boot> set tty com0
Invoke the serial console at every boot:
# echo "set tty com0" > /etc/boot.conf
Boot the kernel named /bsd from the second
hard disk in “User Kernel Configuration” mode (see
mechanism allows for the explicit enabling and disabling of devices during
the current boot sequence, as well as the modification of device parameters.
Once booted, such changes can be made permanent by using
boot> boot hd1a:/bsd -c
RFC 1950 describes the zlib library interface.
The official home page for the version of zlib used in this operating system is at http://www.gzip.org/zlib/.OpenBSD 2.1 on the i386 platform, and was later ported to the amd64 platform.
|August 10, 2010||OpenBSD-5.1|