OpenBSD manual page server
HOSTSTATED(8) OpenBSD System Manager's Manual HOSTSTATED(8)
hoststated - Host Status daemon
hoststated [-dnv] [-D macro=value] [-f file]
hoststated is the host status daemon for server load balancing. Its main
purpose is to keep pf(4) tables up to date as well as any related pf rdr
rules. To communicate with pf, hoststated uses the anchor facility. To
enable hoststated to install rulesets through the anchor, the following
line is required in the NAT section of pf.conf(5):
hoststated manipulates three data types: services, tables, and hosts.
Each service represents a pf(4) rdr rule. A service contains at least
one table and one virtual IP which are used to create the proper rule.
Each table contains at least one host, and is mapped to a pf table. Ad-
ditionally a table can be backed up i.e. its content will be swapped by
the content of another table when it is empty. This can be used to serve
static content when a dynamic service goes down. See hoststated.conf(5)
for a more detailed explanation of how to configure hoststated.
hoststatectl(8) can be used to enable or disable hosts, tables, and ser-
vices as well as showing the current status of each object.
The options are as follows:
Define macro to be set to value on the command line. Overrides
the definition of macro in the configuration file.
-d Do not daemonize. If this option is specified, hoststated will
run in the foreground and log to stderr.
Specify an alternative configuration file. The default is
-n Configtest mode. Only check the configuration file for validity.
-v Produce more verbose output.
/etc/hoststated.conf Default hoststated configuration file.
/var/run/hoststated.sock Unix-domain socket used for communication
The hoststated program first appeared in OpenBSD 4.1.
The hoststated program was written by Pierre-Yves Ritschard
<firstname.lastname@example.org> and Reyk Floeter <email@example.com>.
OpenBSD 4.2 May 31, 2007 1