OpenBSD manual page server
HOSTSTATECTL(8) OpenBSD System Manager's Manual HOSTSTATECTL(8)
hoststatectl - control the host status daemon
hoststatectl command [arguments ...]
The hoststatectl program controls the hoststated(8) daemon.
The following commands are available:
host disable [name | id]
Disable a host. Treat it as though it were always down.
host enable [name | id]
Enable the host. Start checking its health again.
Continuously report any changes in the host checking engine and
the pf engine.
reload Reload the configuration file.
service disable [name | id]
Disable a service. If it has pf(4) redirection rules installed,
remove them. Mark the service's main table and - if applicable -
backup table disabled as well.
service enable [name | id]
Enable a service. Mark the service's main table and - if appli-
cable - backup table enabled as well.
Show detailed status of hosts, tables, and services.
Show detailed status of relays including the current and average
access statistics. The statistics will be updated every minute.
Display a list of all relays, services, tables, and hosts.
table disable [name | id]
Disable a table. Consider all hosts disabled. If it is a main
table of a service which has a non-empty backup table, swap the
contents of the pf(4) table with those of the backup table.
table enable [name | id]
Enable a table. Start doing checks for all hosts that aren't in-
dividually disabled again.
/var/run/hoststated.sock Unix-domain socket used for communication
The hoststatectl program first appeared in OpenBSD 4.1.
OpenBSD 4.2 August 2, 2007 1