OpenBSD manual page server
TWE(4) OpenBSD Programmer's Manual TWE(4)
twe - 3ware Escalade RAID driver
twe* at pci? dev ? function ?
scsibus* at twe?
The twe driver provides support for Escalade family of raid controllers,
including the 3W-5x00 and 3W-6x00 models.
These controllers support RAID 0, RAID 1, RAID 10 and JBOD configura-
tions. All the RAID set volume management is done via the card BIOS.
Even though the card uses IDE drives, this driver makes drives and/or
RAID sets appear as sd(4).
intro(4), scsi(4), sd(4)
The twe driver was written by Michael Shalayeff <firstname.lastname@example.org>, in-
spired by the FreeBSD driver by
Mike Smith <email@example.com>.
The twe driver first appeared in OpenBSD 2.8.
The card's BIOS seems to conflict with some other disk controllers which
have their own BIOS, if such devices are configured earlier than this
one. To avoid this situation, place twe cards in the lowest numbered
slot before other SCSI or RAID disk controllers.
The current 3ware firmware is known to fail if a redundant configuration
is selected (RAID0 or RAID10) and the array is heavily used (e.g. instal-
lation) before the controller has finished initialising the array. In
this case, create the array, boot the installation media and leave the
array idle until all controller activity has ceased.
None of the volumes management or monitoring functions, provided by the
card's firmware, is supported due to the fact that information on these
functions is not public.
Only 3W-5400 was tested, but others should work.
OpenBSD 2.9 September 15, 2000 1