OpenBSD manual page server
AN(4) OpenBSD Programmer's Manual (i386) AN(4)
an - Aironet Communications 4500/4800 IEEE 802.11DS network adapter
an* at pcmcia? function ?
an* at pci? dev ? function ?
The an driver provides support for Aironet Communications 4500 and 4800
IEEE 802.11 Direct Sequence wireless network adapters. This includes the
ISA, PCI, and PCMCIA varieties. The 4500 series adapters operate at 1
and 2Mbps while the 4800 series can operate at 1, 2, 5.5, and 11Mbps.
The ISA, PCI, and PCMCIA devices are all based on the same core PCMCIA
modules and all have the same programming interface. However, unlike the
Lucent WaveLAN/IEEE cards, the ISA and PCI cards appear to the host as
normal ISA and PCI devices and do not require any pcmcia support.
ISA cards can either be configured to use ISA Plug and Play or to use a
particular I/O address and IRQ by properly setting the DIP switches on
the board. (The default switch setting is for plug and play.) The an
driver has Plug and Play support and will work in either configuration,
however when using a hard-wired I/O address and IRQ, the driver configu-
ration and the NIC's switch settings must agree. PCI cards require no
switch settings of any kind and will be automatically probed and at-
All host/device interaction with the Aironet cards is via programmed I/O.
The Aironet devices support 802.11 and 802.3 frames, power management,
BSS (infrastructure), and IBSS (ad-hoc) operation modes. The an driver
encapsulates all IP and ARP traffic as 802.11 frames, however, it can re-
ceive either 802.11 or 802.3 frames. Transmit speed is selectable be-
tween 1Mbps, 2Mbps, 5.5Mbps, 11Mbps or "auto" (the NIC automatically
chooses the best speed).
By default, the an driver configures the Aironet card for ad-hoc opera-
tion with an SSID of "ANY." In this mode, stations can communicate among
each other without the aid of an access point. To join a service set,
the driver must be set for BSS mode using the ancontrol(8) utility.
For more information on configuring this device, see ifconfig(8).
an%d: init failed The Aironet card failed to come ready after an ini-
tialization command was issued.
an%d: failed to allocate %d bytes on NIC The driver was unable to allo-
cate memory for transmit frames in the NIC's on-board RAM.
an%d: device timeout The Aironet card failed to generate an interrupt to
acknowledge a transmit command.
wi(4) arp(4), netintro(4), ifconfig(8), ancontrol(8)
The an device driver first appeared in FreeBSD 4.0. OpenBSD support was
added in OpenBSD 2.7.
The an driver was written by Bill Paul <email@example.com> and ported
to OpenBSD by Michael Shalayeff <firstname.lastname@example.org>.
OpenBSD 2.7 September 10, 1999 1