|SCHEDCTL(8)||System Manager's Manual||SCHEDCTL(8)|
schedctl — control
scheduling of processes and threads
schedctl command can be used to
control the scheduling of processes and threads. It also returns information
about the current scheduling parameters of the process or thread. Only the
super-user may change the scheduling parameters.
schedctl can also be used to start a new command
using the specified parameters.
SCHED_PRI_MAX(63). Setting of priority for the process or thread running at
SCHED_OTHERpolicy is not allowed.
-p is not given, a command to
execute must be given on the command line.
-pis also given.
Show scheduling information about the process whose ID is “123”:
# schedctl -p 123
Set the affinity to CPU 0 and CPU 1, policy to
SCHED_RR, and priority to 63 for thread whose ID is
“1” in process whose ID is “123”:
# schedctl -p 123 -t 1 -A 0,1 -C SCHED_RR -P 63
Run the top(1) command with real-time priority:
# schedctl -C SCHED_FIFO top
schedctl command first appeared in
|March 21, 2011||NetBSD-7.0.1|