|RMT(8)||System Manager's Manual||RMT(8)|
rmt — remote
magtape protocol module
rmt is a program used by the remote dump
and restore programs in manipulating a magnetic tape drive through an
interprocess communication connection.
normally started up with an
rmt program accepts requests specific
to the manipulation of magnetic tapes, performs the commands, then responds
with a status indication. All responses are in ASCII and in one of two
forms. Successful commands have responses of:
Number is an ASCII representation of a decimal number. Unsuccessful commands are responded to with:
Error-number is one of the possible error
numbers described in intro(2)
and error-message is the corresponding error string as
printed from a call to
perror(3). The protocol
comprises the following commands, which are sent as indicated - no spaces
are supplied between the command and its arguments, or between its
arguments, and ‘
\n’ indicates that a
newline should be supplied:
rmtreads count bytes from the connection, aborting if a premature end-of-file is encountered. The response value is that returned from the write(2) call.
rmtthen performs the requested read(2) and responds with Acount-read\n if the read was successful; otherwise an error in the standard format is returned. If the read was successful, the data read is then sent.
MTIOCOPioctl(2) command using the specified parameters. The parameters are interpreted as the ASCII representations of the decimal values to place in the mt_op and mt_count fields of the structure used in the ioctl(2) call. The return value is the count parameter when the operation is successful.
MTIOCGETioctl(2) call. If the operation was successful, an ``ack'' is sent with the size of the status buffer, then the status buffer is sent (in binary).
Any other command causes
rmt to exit.
All responses are of the form described above.
rmt command appeared in
People should be discouraged from using this for a remote file access protocol.
|June 1, 1994||NetBSD-7.0.1|