|PTY(4)||Device Drivers Manual||PTY(4)|
pty — pseudo
pty driver provides support for a
device-pair termed a pseudo terminal. A pseudo terminal is
a pair of character devices, a master device and a
slave device. The slave device provides to a process an
interface identical to that described in
tty(4). However, whereas all
other devices which provide the interface described in
tty(4) have a hardware device
of some sort behind them, the slave device has, instead, another process
manipulating it through the master half of the pseudo terminal. That is,
anything written on the master device is given to the slave device as input
and anything written on the slave device is presented as input on the master
Pseudo terminal pairs are allocated on as-needed basis, maximum number of them is controlled via kern.maxptys sysctl (defaults to 992).
The following ioctl(2) calls apply only to pseudo terminals:
TIOCPKT_IOCTLpackets. External processing is enabled by specifying (by reference) a nonzero int parameter and disabled by specifying (by reference) a zero int parameter.
TIOCEXT is reset to its default
(disabled) when the slave closes the
^S’). Takes no parameter.
TIOCSTOPor by typing ‘
^S’). Takes no parameter.
TIOCPKT_DATA), or a single byte reflecting control status information. In the latter case, the byte is an inclusive-or of zero or more of the bits:
^S’ and t_startc is ‘
While this mode is in use, the presence of control status information to be read from the master side may be detected by a select(2) for exceptional conditions.
ptyis the new termios(4) structure. The master side of the
ptycan also use tcgetattr(3) to read the new termios(4) structure.
The master will not read packets with the bit
TIOCPKT_IOCTL set until it has activated
“external processing” using
This is used by telnetd(8) to implement TELNET "line mode" - it allows the telnetd(8) to detect tty(4) state changes by the slave, and negotiate the appropriate TELNET protocol equivalents with the remote peer.
TIOCPKTmodes are mutually exclusive. This mode is enabled from the master side of a pseudo terminal by specifying (by reference) a nonzero int parameter and disabled by specifying (by reference) a zero int parameter. Each subsequent read(2) from the master side will return data written on the slave part of the pseudo terminal preceded by a zero byte, or a single byte reflecting a user control operation on the slave side. A user control command consists of a special ioctl(2) operation with no data; the command is given as
UIOCCMD(n), where n is a number in the range 1-255. The operation value n will be received as a single byte on the next read(2) from the master side. The ioctl(2)
UIOCCMD(0) is a no-op that may be used to probe for the existence of this facility. As with
TIOCPKTmode, command operations may be detected with a select(2) for exceptional conditions.
TIOCPKT. This mode causes input to the pseudo terminal to be flow controlled and not input edited (regardless of the terminal mode). Each write to the control terminal produces a record boundary for the process reading the terminal. In normal usage, a write of data is like the data typed as a line on the terminal; a write of 0 bytes is like typing an end-of-file character.
TIOCREMOTEcan be used when doing remote line editing in a window manager, or whenever flow controlled input is required.
pty driver appeared in
|November 30, 2013||NetBSD-7.0.1|