|MOUNT(8)||System Manager's Manual||MOUNT(8)|
mount — mount file
mount command invokes a file
system-specific program to prepare and graft the
special device on to the file system tree at the point
node, or to update options for an already-mounted file
The node argument is always interpreted as a directory in the name space of currently mounted file systems. The special argument is interpreted in different ways by the programs that handle different file system types; for example, mount_ffs(8) interprets it as a device node, mount_null(8) interprets it as a directory name, mount_nfs(8) interprets it as reference to a remote host and a directory on that host, and mount_tmpfs(8) ignores it.
The system maintains a list of currently mounted file systems.
This list is printed if
mount is invoked with no
arguments, and with no options that require some other behaviour.
If exactly one of special or
node is provided, then the missing information
(including the file system type) is taken from the
fstab(5) file. The provided
argument is looked up first in the “fs_file”, then in the
“fs_spec” column. If the matching entry in
fstab(5) has the string
from_mount” as its
“fs_spec” field, the device or remote file system already
mounted at the location specified by “fs_spec” will be
If both special and
node are provided, then
fstab(5) is not used. In this
case, if the file system type is not specified via the
-t flag, then
determine the type from the disk label (see
addition, if special contains a colon
:’) or at sign
@’), then the
nfs type is inferred, but this behaviour is
deprecated, and will be removed in a future version of
In NetBSD, the file-system mounting policy is dictated by the running security models. The default security model may allow unprivileged mounting; see secmodel_suser(9) and secmodel_extensions(9) for details.
The options are as follows:
mountto try to mount all of the file systems listed in the fstab(5) file except those for which the “noauto” option is specified.
-Aflag, except that if a file system (other than the root file system) appears to be already mounted,
mountwill not try to mount it again.
mountassumes that a file system is already mounted if a file system with the same type is mounted on the given mount point. More stringent checks are not possible because some file system types report strange values for the mounted-from device for mounted file systems.
-vflag to determine what the
mountcommand is trying to do.
-oflag followed by a comma separated string of options. The following options are available:
-f; forces the revocation of write access when trying to downgrade a file system mount status from read-write to read-only.
MNT_IGNOREflag, causes the mount point to be excluded from the list of file systems shown by default with df(1).
-r; mount the file system read-only (even the super-user may not write it).
-tflag and respective rump_type manual page for more information.
logcan not be mounted with
async. It requires the
WAPBLoption to be enabled in the running kernel. See wapbl(4) for more information. This option requires the “UFS2” (level 4) superblock layout, which is the default for newly created FFSv1 and FFSv2 file systems. To update an old file system with an earlier superblock format, use the
-coption of fsck_ffs(8).
Note that the
union option can be
applied to any type of file system, and is fundamentally different
which is a particular type of file system. Also note that the
union option affects the file system name
space only at the mount point itself; it does not apply recursively
-u; indicate that the status of an already mounted file system should be changed.
Any additional options specific to a given file system type
-t option) may be passed as a comma
separated list; these options are distinguished by a leading
“-” (dash). Options that take a value are specified using
the syntax -option=value. For example, the mount command:
mount -t mfs -o nosuid,-N,-s=32m swap /tmp
mount to execute the equivalent
/sbin/mount_mfs -o nosuid -N -s 32m swap /tmp
-tis used to indicate the file system type. The type ffs is the default. The
-toption can be used to indicate that the actions should only be taken on file systems of the specified type. More than one type may be specified in a comma separated list. The list of file system types can be prefixed with “no” to specify the file system types for which action should not be taken. For example, the
mount -a -t nonfs,mfs
mounts all file systems except those of type NFS and MFS.
mount will attempt to execute a
program in /sbin/mount_XXX
where XXX is replaced by the type name. For example,
nfs file systems are mounted by the program
-uflag indicates that the status of an already mounted file system should be changed. Any of the options discussed above (the
-ooption) may be changed; also a file system can be changed from read-only to read-write or vice versa. An attempt to change from read-write to read-only will fail if any files on the file system are currently open for writing unless the
-fflag is also specified. The set of options is determined by first extracting the options for the file system from the fstab(5) file, then applying any options specified by the
-oargument, and finally applying the
The options specific to the various file system types are
described in the manual pages for those file systems'
mount_XXX commands; for instance, the options
specific to Berkeley Fast File System (FFS) are described in the
The particular type of file system in each partition of a disk can be found by examining the disk label with the disklabel(8) command.
Some useful examples:
The “noauto” directive in /etc/fstab can be used to make it easy to manually mount and unmount removable media using just the mountpoint filename, with an entry like this:
/dev/cd0a /cdrom cd9660 ro,noauto 0 0
That would allow a simple command like "mount /cdrom" or "umount /cdrom" for media using the ISO-9660 file system format in the first CD-ROM drive.
The error “Operation not supported by device” indicates that the mount for the specified file-system type cannot be completed because the kernel lacks support for the said file-system. See options(4).
The error “Operation not permitted” may indicate that the mount options include privileged options and/or don't include options that exclude privileged options. One should try using at least “nodev” and “nosuid” in such cases:
mount -t cd9660 -o nodev,nosuid /dev/cd0a /mnt
df(1), mount(2), options(4), wapbl(4), fstab(5), disklabel(8), fsck(8), mount_ados(8), mount_cd9660(8), mount_ext2fs(8), mount_fdesc(8), mount_ffs(8), mount_filecore(8), mount_kernfs(8), mount_lfs(8), mount_mfs(8), mount_msdos(8), mount_nfs(8), mount_ntfs(8), mount_null(8), mount_overlay(8), mount_portal(8), mount_procfs(8), mount_tmpfs(8), mount_udf(8), mount_umap(8), mount_union(8), rump_cd9660(8), rump_efs(8), rump_ext2fs(8), rump_ffs(8), rump_hfs(8), rump_lfs(8), rump_msdos(8), rump_nfs(8), rump_ntfs(8), rump_smbfs(8), rump_sysvbfs(8), rump_tmpfs(8), rump_udf(8), umount(8)
mount command appeared in
Version 6 AT&T UNIX.
|October 31, 2013||NetBSD-7.0.1|