|EHCI(4)||Device Drivers Manual||EHCI(4)|
ehci — USB
Enhanced Host Controller driver
ehci* at cardbus? function ?
ehci* at pci? dev ? function ?
usb* at ehci?
ehci driver provides support for the
USB Enhanced Host Controller Interface, which is used by USB 2.0
EHCI controllers are peculiar in that they can only handle the USB 2.0 protocol. This means that they normally have one or more companion controllers (i.e., ohci(4) or uhci(4)) handling USB 1.x devices. Consequently each USB connector is electrically connected to two USB controllers. The handling of this is totally automatic, but can be noticed since USB 1.x and USB 2.0 devices plugged in to the same connector appear to connect to different USB busses.
ehci driver appeared in
The support for hubs that are connected with high speed upstream and low or full speed downstream (i.e., for transaction translators) is limited.
|August 10, 2008||NetBSD-7.0.1|