|DEV_MKDB(8)||System Manager's Manual||DEV_MKDB(8)|
dev_mkdb — create
dev_mkdb command creates a
cdbr(3) database in
“/var/run/dev.cdb” which contains the
names of all of the character and block special files in the specified
directory, using the file type and the st_rdev field
as the key. If no directory is specified, the
“/dev” directory is used.
Keys are a structure containing a mode_t followed by a dev_t, with any padding zero'd out. The former is the type of the file (st_mode & S_IFMT), the latter is the st_rdev field.
The options are as follows:
dev_mkdb command appeared in
|June 1, 2012||NetBSD-7.0.1|