|CHOWN(8)||System Manager's Manual||CHOWN(8)|
chown — change
file owner and group
chown sets the user ID and/or the group ID
of the specified files.
The options are as follows:
-Roption is specified, symbolic links on the command line are followed. (Symbolic links encountered in the tree traversal are not followed.)
-Roption is specified, all symbolic links are followed.
-Roption is specified, no symbolic links are followed.
chownto be verbose, showing files as they are processed.
-P options are ignored unless the
-R option is specified. In addition, these options
override each other and the command's actions are determined by the last one
specified. The default is as if the
-P option had
-L option cannot be used together with
The owner and group
operands are both optional, however, one must be specified; alternatively,
both the owner and group may be specified using a reference
rfile specified using the
-reference argument. If the
group operand is specified, it must be preceded by a
colon (``:'') character.
The owner may be either a user name or a numeric user ID. The group may be either a group name or a numeric group ID. Since it is valid to have a user or group name that is numeric (and doesn't have the numeric ID that matches its name) the name lookup is always done first. Preceding an ID with a ``#'' character will force it to be taken as a number.
The ownership of a file may only be altered by a super-user for obvious security reasons.
Unless invoked by the super-user,
clears the set-user-id and set-group-id bits on a file to prevent accidental
or mischievous creation of set-user-id and set-group-id programs.
chown utility exits 0 on success, and
>0 if an error occurs.
Previous versions of the
used the dot (``.'') character to distinguish the group name. This has been
changed to be a colon (``:'') character so that user and group names may
contain the dot character.
chown command is expected to be POSIX
-v option and the use of ``#'' to
force a numeric lookup are extensions to IEEE Std 1003.2
|October 22, 2012||NetBSD-7.0.1|