OpenBSD manual page server

Manual Page Search Parameters

VFLUSH(9) Kernel Developer's Manual VFLUSH(9)

vflushflush vnodes for a mount point

#include <sys/param.h>
#include <sys/vnode.h>

int
vflush(struct mount *mp, struct vnode *skipvp, int flags);

The () function removes any vnodes in the vnode table that belong to the given mount structure.

Its arguments are:

mp
The mount point whose vnodes should be removed.
skipvp
If this is given, the vnode it represents will be skipped.
flags
The flags indicating how vnodes should be handled.
If set, busy vnodes will be forcibly closed.
If set, vnodes with the VSYSTEM flag set will be skipped.
If set, only regular files currently opened for writing will be removed.

A value of 0 is returned if the flush is successful; otherwise, EBUSY will be returned.

vgone(9), vgonel(9), vnode(9), vrele(9)

This man page was originally written by Chad David <davidc@acns.ab.ca> for FreeBSD.

November 14, 2020 OpenBSD-current