OpenBSD manual page server

Manual Page Search Parameters

UVM_FAULT(9) Kernel Developer's Manual UVM_FAULT(9)

uvm_faultpage fault handling

#include <sys/param.h>
#include <uvm/uvm.h>

int
uvm_fault(vm_map_t orig_map, vaddr_t vaddr, vm_fault_t fault_type, vm_prot_t access_type);

The () function is the main entry point for faults. It takes orig_map as the map the fault originated in, a vaddr offset into the map the fault occurred, fault_type describing the type of fault, and access_type describing the type of access requested. uvm_fault() returns a standard errno.

pmap(9)

December 5, 2019 OpenBSD-current