|PWDOG(4)||Device Drivers Manual||PWDOG(4)|
pwdog — Quancom
PWDOG1 watchdog timer device
pwdog0 at pci?
pwdog driver provides support for
Quancom PWDOG1 boards.
If the kernel crashes, the watchdog timer is not reset and the system will reboot (assuming a proper connection is made between the PWDOG1 and the motherboard). Alternatively, the watchdog can be reinitialized via a userland process which ensures that process scheduling, not just kernel timeout processing, is still taking place. See watchdog(4) and watchdogd(8) for more information.
The timeout period of the PWDOG1 card is set using DIP switches and cannot be changed by software.
pwdog driver first appeared in
pwdog driver was written by
|July 16, 2013||OpenBSD-current|