|PING(8)||System Manager's Manual||PING(8)|
pinguses the ICMP protocol's mandatory
ECHO_REQUESTdatagram to elicit an ICMP
ECHO_REPLYfrom a host or gateway. These datagrams (pings) have an IP and ICMP header, followed by a “struct timeval” and then an arbitrary number of pad bytes used to fill out the packet.
The options are as follows:
ECHO_REQUESTpackets have been sent. If count is 0, send an unlimited number of packets.
SO_DEBUGoption on the socket being used. This option has no effect on OpenBSD.
ECHO_REQUESTsent, a period ‘.’ is printed, while for every
ECHO_REPLYreceived a backspace is printed. This provides a rapid display of how many packets are being dropped. Only the superuser may use this option.
RECORD_ROUTEoption in the
ECHO_REQUESTpacket and displays the route buffer on returned packets. Note that the IP header is only large enough for nine such routes. If more routes come back than should, such as due to an illegal spoofed packet,
pingwill print the route list and then truncate it at the correct spot. Many hosts ignore or discard this option.
reliability, or one of the DiffServ Code Points:
af11 ... af43,
cs0 ... cs7; or a number in either hex or decimal.
ECHO_REPLYthat are received are listed.
ping for fault isolation, it
should first be run on the local host to verify that the local network
interface is up and running. Then, hosts and gateways further and further
away should be “pinged”.
Round trip times and packet loss statistics are computed. If duplicate packets are received, they are not included in the packet loss calculation, although the round trip time of these packets is used in calculating the minimum/average/maximum round trip time numbers and the standard deviation.
When the specified number of packets have been sent (and
received), or if the program is terminated with a
SIGINT, a brief summary is displayed. The summary
information can also be displayed while
running by sending it a
SIGINFO signal (see the
status argument of
stty(1) for more information).
This program is intended for use in network testing, measurement
and management. Because of the load it can impose on the network, it is
unwise to use
ping during normal operations or from
ECHO_REQUESTpacket contains an additional 8 bytes worth of ICMP header followed by an arbitrary amount of data. When a packetsize is given, this indicates the size of this extra piece of data (the default is 56). Thus the amount of data received inside of an IP packet of type ICMP
ECHO_REPLYwill always be 8 bytes more than the requested data space (the ICMP header).
If the data space is at least 24 bytes,
ping uses the first sixteen bytes of this space to
include a timestamp which it uses in the computation of round trip times.
The following 8 bytes store a message authentication code. If less than 24
bytes of pad are specified, no round trip times are given.
pingwill report duplicate and damaged packets. Duplicate packets should never occur, and seem to be caused by inappropriate link-level retransmissions. Duplicates may occur in many situations and are rarely (if ever) a good sign, although the presence of low levels of duplicates may not always be cause for alarm.
Damaged packets are obviously serious cause for alarm and often
indicate broken hardware somewhere in the
packet's path (in the network or in the hosts).
This means that if you have a data-dependent problem you will
probably have to do a lot of testing to find it. If you are lucky, you may
manage to find a file that either can't be sent across your network or that
takes much longer to transfer than other similar length files. You can then
examine this file for repeated patterns that you can test using the
-p option of
The TCP/IP specification states that the TTL field for TCP packets should be set to 60, but many systems use smaller values (4.3BSD uses 30, 4.2BSD used 15).
The maximum possible value of this field is 255, and most
UNIX systems set the TTL field of ICMP
ECHO_REQUEST packets to 255. This is why you will
find you can “ping” some hosts, but not reach them with
In normal operation,
ping prints the TTL
value from the packet it receives. When a remote system receives a ping
packet, it can do one of three things with the TTL field in its
pingexits 0 if at least one reply is received, and >0 if no reply is received or an error occurred. netstat(1), ifconfig(8)
pingcommand appeared in 4.3BSD. The
ping6command was originally a separate program and first appeared in the WIDE Hydrangea IPv6 protocol stack kit.
The maximum IP header length is too small for options like
RECORD_ROUTE to be completely useful. There's not
much that can be done about this, however.
Flood pinging is not recommended in general, and flood pinging the broadcast address should only be done under very controlled conditions.
|November 10, 2018||OpenBSD-current|