|nvram(4/amd64)||driver for reading PC NVRAM contents|
|nvram(4/i386)||driver for reading PC NVRAM contents|
|NVRAM(4)||Device Drivers Manual (amd64)||NVRAM(4)|
nvram — driver for
reading PC NVRAM contents
pseudo-device nvram 1
nvram device provides read-only access
to the non-volatile memory contained in the MC146818 real-time clock.
This data is provided as a seekable character device, /dev/nvram. Checksums of the NVRAM contents are calculated over bytes 2 to 31 and stored in byte 32. A valid checksum is required for the driver to initialize.
nvram support was originally included in
|August 2, 2007||OpenBSD-current|