|MOUNT_MSDOS(8)||System Manager's Manual||MOUNT_MSDOS(8)|
mount an MS-DOS file system
mount_msdos command attaches the
MS-DOS file system residing on the device special to
the global file system namespace at the location indicated by
node. This command is invoked by
mount(8) when using the syntax
mount[options] -t msdos special node
The special device must correspond to a partition registered in the disklabel(5).
This command is normally executed by mount(8) at boot time, but can be used by any user to mount an MS-DOS file system on any directory that they own (provided, of course, that they have appropriate access to the device that contains the file system).
The options are as follows:
This is the default.
File permissions for FAT file systems are imitated, since the file
system has no real concept of permissions. The default mask is taken from
the directory on which the file system is being mounted, except when the
-m option is used. FAT does have a “read
only” mode, in which the writable bit is unset. If such files are
found, they are marked non-writable; it can be set using
chmod -w or unset using
File modes work the same way for directories. However a directory will inherit the executable bit if it is readable. See chmod(1) for more information about octal file modes.
mount_msdos utility first appeared in
NetBSD 0.9. Its predecessor, the
mount_pcfs utility, appeared in
NetBSD 0.8, and was abandoned in favor of the more
The original code was written by Paul Popelka <firstname.lastname@example.org> as a patch to 386BSD-0.1 in November 1992. The current version is based on code written by Christopher G. Demetriou <email@example.com> in April 1994.
The maximum file size supported by the MS-DOS file system is one byte less than 4GB. This is a FAT file system limitation, documented by Microsoft in Knowledge Base article 314463.
The MS-DOS file system (even with long filenames) does not support filenames with trailing dots or spaces. Any such characters will be silently removed before the directory entry is written. This too is a FAT file system limitation.
The use of the
-9 flag could result in
damaged file systems, albeit the damage is in part taken care of by
procedures similar to the ones used in Windows 95/98.
Note that Windows 95/98 handles only access dates, but not access times.
|November 13, 2021||OpenBSD-current|