|SYSPATCH(8)||System Manager's Manual||SYSPATCH(8)|
syspatch — manage
base system binary patches
syspatch is a utility to fetch, verify,
install and revert OpenBSD binary patches.
When run without any options,
syspatch will apply
all missing patches,
creating a rollback tarball containing the files it is about to replace,
then extracting and installing all files contained in the syspatch tarball.
If any sets are missing, patches are skipped accordingly. Patches are
cumulative and as such it is not possible to install only a subset of
The options are as follows:
syspatch utility exits 0 on
success, and >0 if an error occurs. In particular, 2 indicates
that applying patches was requested but no additional patch was
syspatch first appeared in
syspatch was written by
syspatch is designed to work solely on
official OpenBSD releases.
|December 7, 2020||OpenBSD-current|