OpenBSD manual page server

Manual Page Search Parameters

APM(4) Device Drivers Manual (arm64) APM(4)

apmpower management interface

apm0 at mainbus?

The apm driver provides an interface which simulates the Advanced Power Management (APM) BIOS functions.

Suspend/resume and other power events are NOT YET SUPPORTED.

The apm driver implements the following ioctl(2) calls. They are defined in <machine/apmvar.h>.

. .
.

(no parameters) Request “standby” mode.

.

(no parameters) Request “suspend” mode.

.

(no parameters) Request “hibernate” mode.

(struct apm_power_info) Request the current power state. The argument structure is as follows:
struct apm_power_info {
	u_char battery_state;
	u_char ac_state;
	u_char battery_life;
	u_char spare1;
	u_int minutes_left;
	u_int spare2[6];
};

The following values are defined for battery_state:

Battery has a high state of charge.
Battery has a low state of charge.
Battery has a critical state of charge.
Battery is not high, low, or critical and is currently charging.
Cannot read the current battery state.
No battery installed.

The following values are defined for ac_state:

External power not detected.
External power detected.
Backup power in use.
External power state unknown.

The battery_life value contains the estimated percentage of battery life available. 100% indicates a full charge.

The minutes_left value contains the estimated number of minutes of battery life remaining.

.

(struct apm_ctl) Allows an application to directly set the APM operating mode. The argument structure is as follows:

struct apm_ctl {
	u_int dev;
	u_int mode;
};

dev indicates the device, typically APM_DEV_ALLDEVS.

mode indicates the desired operating mode. Possible values are

(int) This ioctl(2) controls message output by the APM driver when a power change event is detected. The integer parameter is one of:
All power change events result in a message. This is the normal operating mode for the driver.
Power change event messages are suppressed.
Power change event messages are suppressed unless the estimated battery life percentage changes.

/dev/apm
Power management data device. May only be opened read-only. May be opened by multiple concurrent users.
/dev/apmctl
Power management control device. May be opened read-write or write-only. May only be opened by one user at a time. An attempt to open the file when in use will fail, returning EBUSY.

acpi(4), intro(4), halt(8)

January 30, 2023 OpenBSD-current