|KGMON(8)||System Manager's Manual||KGMON(8)|
kgmonis a tool used when profiling the operating system. When no arguments are supplied,
kgmonindicates the state of per-CPU operating system profilings as “running”, “off”, or “not configured” (see config(8)). If the
-pflag is specified,
kgmonextracts profile data from the operating system and produces a file for each CPU suitable for later analysis by gprof(1).
The options are as follows:
-pflag is also specified, the profile files are generated before the buffers are reset.
-h is specified, the state of profiling collection
remains unchanged. For example, if the
-p flag is
specified and profile data is being collected, profiling will be momentarily
suspended, the operating system profile buffers will be dumped, and
profiling will be immediately resumed.
kgmon requires the ability to open
/dev/kmem which may be restricted based upon the
value of the kern.allowkmem
kgmoncommand appeared in 4.2BSD.
|September 25, 2016||OpenBSD-current|