|IWM(4)||Device Drivers Manual||IWM(4)|
iwm — Intel
7000/8000/9000 IEEE 802.11a/ac/b/g/n wireless network devices
iwm* at pci?
iwm driver provides support for Intel
Wireless 7260, 7265, 3160, 3165, 3168, 8260, 8265, and 9260 PCIe Mini Card
and M.2 network adapters, and for Intel Wireless 9560 Integrated
Connectivity (CNVi) network adapters with companion RF M.2 modules.
These are the modes the
iwm driver can
iwm driver can be configured to use
Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA1 and WPA2).
WPA2 is the current encryption standard for wireless networks. It is
strongly recommended that neither WEP nor WPA1 are used as the sole
mechanism to secure wireless communication, due to serious weaknesses. WPA1
is disabled by default and may be enabled using the option
wpa1,wpa2". For standard WPA networks which use
pre-shared keys (PSK), keys are configured using the
wpakey" option. WPA-Enterprise networks
require use of the wpa_supplicant package. The
driver offloads both encryption and decryption of unicast data frames to the
hardware for the CCMP cipher.
In BSS mode the driver supports background scanning; see ifconfig(8).
The driver needs one of the following firmware files, which are loaded when an interface is brought up:
These firmware files are not free because Intel refuses to grant distribution rights without contractual obligations. As a result, even though OpenBSD includes the driver, the firmware files cannot be included and users have to download these files on their own.
A prepackaged version of the firmware can be installed using fw_update(1).
The following example scans for available networks:
# ifconfig iwm0 scan
The following hostname.if(5) example configures iwm0 to join network “mynwid”, using WPA key “mywpakey”, obtaining an IP address using DHCP:
join mynwid wpakey mywpakey inet autoconf
iwm device driver first appeared in
iwm driver does not support any of the
802.11ac capabilities offered by the adapters. Additional work is required
in ieee80211(9) before those features
can be supported.
This driver does not support powersave mode.
|October 24, 2021||OpenBSD-current|