|IPW(4)||Device Drivers Manual||IPW(4)|
ipw* at pci?
ipwdriver provides support for the Intel PRO/Wireless 2100 Mini PCI network adapter.
These are the modes the
ipw driver can
ipw driver can be configured to use
Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA-PSK and
WPA2-PSK). WPA is the current encryption standard for wireless networks. It
is strongly recommended that WEP not be used as the sole mechanism to secure
wireless communication, due to serious weaknesses in it. The
ipw driver relies on the software 802.11 stack for
both encryption and decryption of data frames.
These firmware files are not free because Intel refuses to grant distribution rights without contractual obligations. As a result, even though OpenBSD includes the driver, the firmware files cannot be included and users have to find these files on their own. The official person to state your views to about this issue is email@example.com.
A prepackaged version of the firmware can be installed using fw_update(1).
# ifconfig ipw0 scan
The following hostname.if(5) example configures ipw0 to join network “mynwid”, using WPA key “mywpakey”, obtaining an IP address using DHCP:
nwid mynwid wpakey mywpakey dhcp
ipwdriver first appeared in OpenBSD 3.7.
ipwdriver was written by Damien Bergamini <firstname.lastname@example.org>.
|July 15, 2018||OpenBSD-current|